Trouver la valeur supérieure la plus proche

[Résolu/Fermé]
Signaler
Messages postés
29
Date d'inscription
jeudi 21 février 2013
Statut
Membre
Dernière intervention
23 janvier 2015
-
Messages postés
29
Date d'inscription
jeudi 21 février 2013
Statut
Membre
Dernière intervention
23 janvier 2015
-
Bonjour,

Je recherche une fonction SIMPLE qui me permet de rechercher dans une liste la valeur supérieure la plus proche à une valeur donnée.

Par exemple, dans la liste:

10
13
17

Si je demande la valeur supérieure la plus proche de 14, je m'attends à obtenir 17.

La fonction recherche ne fait que trouver la valeur inférieure la plus proche.

Ça me semble simple comme fonction, mais je n'ai encore rien trouvé de simple qui permettrait d'exécuter ceci.

Merci de votre aide.
A voir également:

2 réponses

Messages postés
26219
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2021
6 083
Bonjour
pour une liste de valeurs en colonne A, obligatoirement classées en ordre croissant, et une valeur cherchée en C2:

=INDEX(A:A;EQUIV(C2;A:A)+1))

renvoie la valeur supérieure même si la valeur exacte de C2 se trouve dans la liste

pour éviter ça si besoin on peut écrire:

=SI(NB.SI(A:A;C2);C2;INDEX(A:A;EQUIV(C2;A:A)+1)))

crdlmnt

Errare humanum est, perseverare diabolicum
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
29
Date d'inscription
jeudi 21 février 2013
Statut
Membre
Dernière intervention
23 janvier 2015
2
Merci!