Trouver la valeur supérieure la plus proche

Résolu/Fermé
Thibodeau19 Messages postés 29 Date d'inscription jeudi 21 février 2013 Statut Membre Dernière intervention 23 janvier 2015 - 23 sept. 2014 à 19:43
Thibodeau19 Messages postés 29 Date d'inscription jeudi 21 février 2013 Statut Membre Dernière intervention 23 janvier 2015 - 23 sept. 2014 à 20:53
Bonjour,

Je recherche une fonction SIMPLE qui me permet de rechercher dans une liste la valeur supérieure la plus proche à une valeur donnée.

Par exemple, dans la liste:

10
13
17

Si je demande la valeur supérieure la plus proche de 14, je m'attends à obtenir 17.

La fonction recherche ne fait que trouver la valeur inférieure la plus proche.

Ça me semble simple comme fonction, mais je n'ai encore rien trouvé de simple qui permettrait d'exécuter ceci.

Merci de votre aide.
A voir également:

2 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 285
Modifié par Vaucluse le 23/09/2014 à 20:02
Bonjour
pour une liste de valeurs en colonne A, obligatoirement classées en ordre croissant, et une valeur cherchée en C2:

=INDEX(A:A;EQUIV(C2;A:A)+1))

renvoie la valeur supérieure même si la valeur exacte de C2 se trouve dans la liste

pour éviter ça si besoin on peut écrire:

=SI(NB.SI(A:A;C2);C2;INDEX(A:A;EQUIV(C2;A:A)+1)))

crdlmnt

Errare humanum est, perseverare diabolicum
2