Recherche d'une valeur EXACTE

Résolu/Fermé
Signaler
Messages postés
3
Date d'inscription
vendredi 19 septembre 2014
Statut
Membre
Dernière intervention
19 septembre 2014
-
Messages postés
3
Date d'inscription
vendredi 19 septembre 2014
Statut
Membre
Dernière intervention
19 septembre 2014
-
Bonjour,

Pouvez-vous me guider pour trouver une valeur exacte sur excel s'il vous plaît ?
Avec la fonction =RECHERCHE(B2;E2:E1350;D2:D1658) j'ai une valeur proche et non exacte
:(
Je souhaite trouver dans ma colonne E la valeur de la colonne B et que le résultat soit la référence de la colonne D.

Désolée, je suis vraiment nulle sur excel
Merci bcp
A voir également:

2 réponses

Messages postés
13214
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
3 décembre 2021
2 291
Bonjour

Il faut alors utiliser RECHERCHEV

=RECHERCHEV(B2;E2:D1658;2;0) le 2 pour renvoi 2eme colonne de la plage, le 0 pour correspondance exacte

Cdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
26309
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 décembre 2021
6 131
euh... bonjour via.
Es tu sur que la formule va chercher dans E pour ressortir une valeur de D?.. ou c'est ma notion de l'alphabet qui me joue des tours?
(de toutes façons, Excel va remettre le champ à l'endroit dans la formule)
:-)
crdlmnt
Messages postés
3
Date d'inscription
vendredi 19 septembre 2014
Statut
Membre
Dernière intervention
19 septembre 2014

Merci pour votre réponse.
Messages postés
26309
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 décembre 2021
6 131
Bonjour

Vous ne pouvez pas trouver avec RECHERCHE un résultat dans une colonne (D) qui précéde la colonne d e recherche (E) (obligatoirement la 1° du champ avec ce code)
voyez avec

=INDEX(D2:D1350;EQUIV(B2;E2:E1350;0))

... et surtout, contrairement à votre formule, veiller à ce que les champs aient la même hauteur!



crdlmnt

Errare humanum est, perseverare diabolicum
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
13214
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
3 décembre 2021
2 291
Bonjour Vaucluse

Tu as raison, je fais de la dyslexie ! pas vu E après D !!!! pff
RECHERCHEV ne peux donc se faire ici

Cdlmnt
Messages postés
3
Date d'inscription
vendredi 19 septembre 2014
Statut
Membre
Dernière intervention
19 septembre 2014

Merci bcp Vaucluse, ça marche très bien !!!!!! MERCI !!!!!!!