Affecter chaque choix d'une liste déroulante une valeur excel

Fermé
Todesfall
Messages postés
70
Date d'inscription
lundi 30 avril 2007
Statut
Membre
Dernière intervention
17 septembre 2014
- 15 sept. 2014 à 18:03
Todesfall
Messages postés
70
Date d'inscription
lundi 30 avril 2007
Statut
Membre
Dernière intervention
17 septembre 2014
- 17 sept. 2014 à 07:28
Bonjour a tous,

Petite question à laquelle je ne trouve pas de réponse malgré avoir épluché plusieurs forums.
J'ai créé une liste :
A1 = a
A2 = b
A3 = c
nommé Liste.

J'ai affecté des valeurs :
B1 = 1
B2 = 2
B3 = 3

En C1 je fais une validation de donnée avec "=Liste" et en D1 je fais une recherchev pour qu'il me sorte la valeur correspondant à la lettre choisi en C1.

En fait je souhaiterai que lorsque je choisi dans ma liste déroulante (cellule C1) la valeur "a", qu'il m'affiche toujours en cellule C1 la valeur "1" et pas "a".

J'espère être clair, n'hésitez pas si ce n'est pas le cas.

Merci d'avance.

4 réponses

Gyrus
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
530
15 sept. 2014 à 18:34
Bonjour,

Le plus simple est de redéfinir la plage nommée "Liste"
=Feuil1!$A$1:$B$3

Puis en D1
=RECHERCHEV(C1;Liste;2;FAUX)

A+
0