Programmer une macro_excel

Résolu/Fermé
LAASRI.reda
Messages postés
26
Date d'inscription
mardi 15 juillet 2014
Statut
Membre
Dernière intervention
21 juillet 2014
- Modifié par LAASRI.reda le 15/07/2014 à 13:49
LAASRI.reda
Messages postés
26
Date d'inscription
mardi 15 juillet 2014
Statut
Membre
Dernière intervention
21 juillet 2014
- 16 juil. 2014 à 23:00
Bonjour !
c'est urgent , j'aimerai bien savoir comment je peux programmer une macro_excel qui répond aux besoins suivant :
- pour chaque ligne de 7 --> 17 , de la ligne 19 -->30 ,de la ligne 32 --> 39 et de la ligne 41 --> 43 on trouves des items : item 1 , item 2 , item 3 ... item n
- la colonne A est reservé pour des items
- la colonne B ----> P sont ecrits des dates
- l intesection ligne-colonne donne la conformité ' c 'ou la non-conformité ' n' de chaque item a une date donné
- objectif :
parcourir chaque ligne du tableau en donnat enfin un pourcentage qui represente a la conformité de l'item :
exemple :

/ date1 / date2 / date3 / .... / daten
item 1 / c / c / c / .... / c
item 2 / n / c / n / / c
item 3 / n / n / n / / n



c : conforme n : non-conforme


on doit ecrire une macro excel qui donne ce pourcentage en ajoutant une autre colonne :

date1 date2 date3 .... daten / pourcentage
item 1 c c c .... c / 100%
item 2 n c n c / 50%
item 3 n n n n / 0%

le pourcentage calculé par : ( nombre de 'c' ) / ( nombre de cases de la ligne pleines ) le tout * 100
Merci d'avance

7 réponses

g
Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
573
15 juil. 2014 à 14:55
Bonjour,

Une simple formule devrait suffire:

=NB.SI(B2:J2;"c")/NBVAL(B2:J2)

à adapter, à mettre au format "Pourcentage" et dérouler vers le bas.

Cordialement.
1
LAASRI.reda
Messages postés
26
Date d'inscription
mardi 15 juillet 2014
Statut
Membre
Dernière intervention
21 juillet 2014

15 juil. 2014 à 15:04
salut !
j'aimerai bien automatiser la tache ... donc la nécessité d'un code VBA ' programmation d'une macro "
Merci infiniment pour l'aide
0
LAASRI.reda
Messages postés
26
Date d'inscription
mardi 15 juillet 2014
Statut
Membre
Dernière intervention
21 juillet 2014

15 juil. 2014 à 15:12
cette macro va donner comme resultat :
item 1 : xx%
item 2 : yy%
item 3: zz %
.
.
item n : aa %
0
LAASRI.reda
Messages postés
26
Date d'inscription
mardi 15 juillet 2014
Statut
Membre
Dernière intervention
21 juillet 2014

15 juil. 2014 à 15:19
autrement dit , la traduction de la formule cité ;

=NB.SI(B2:J2;"c")/NBVAL(B2:J2) en VBA et comment pourrais je généraliser cette formule sur tout les items .
chaque ligne / item va nous donner un pourcentage
0
ccm81
Messages postés
10314
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
25 mai 2022
2 292
15 juil. 2014 à 18:31
Bonjour

Un exemple à adapter
https://www.cjoint.com/?3GpsEFCsIAY

Cdlmnt
1
ccm81
Messages postés
10314
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
25 mai 2022
2 292
16 juil. 2014 à 10:11
Clic-Droit sur l'onglet de la feuille 1, puis Visualiser le code

Cordialement
1
LAASRI.reda
Messages postés
26
Date d'inscription
mardi 15 juillet 2014
Statut
Membre
Dernière intervention
21 juillet 2014

16 juil. 2014 à 01:44
Merci ccm81 , très bon travail , ou puis-je trouver le code de la macro ????
Cordialement
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
LAASRI.reda
Messages postés
26
Date d'inscription
mardi 15 juillet 2014
Statut
Membre
Dernière intervention
21 juillet 2014

16 juil. 2014 à 12:29
Merci infiniment :)
0
ccm81
Messages postés
10314
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
25 mai 2022
2 292
16 juil. 2014 à 15:38
De rien,

Peux tu mettre le sujet à Résolu (en haut à droite de ton premier message)

Bonne fin de journée
0
LAASRI.reda
Messages postés
26
Date d'inscription
mardi 15 juillet 2014
Statut
Membre
Dernière intervention
21 juillet 2014

16 juil. 2014 à 23:00
Oui avec plaisir , c'est déja fait , merci bcq pour votre aide
0