Regrouper des formules..

Résolu/Fermé
Signaler
-
Messages postés
24222
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 novembre 2021
-
Bonjour,

Je cherche à simplifier un tableur excel composé de plusieurs formules nécessitant des copier/coller, sources d'erreurs...

Dans mon tableur, voici les trois types de données numériques dont je dispose :
A1 : <10
B1 : 16,54
C1 : 12<x<13,52

Je souhaiterai en une seule formule :
- supprimer le symbole "<"
- lorsqu'il y a un "x" garder la valeur numérique majorée (soit dans mon exemple 13,52)
- lorsqu'il n'y a pas de "<" ou de "x", garder la valeur numérique (soit ici 16,54)

J'ai essayé avec des formules du genre :
=SUBSTITUE(A1;"<";"")
et =STXT(A1;TROUVE("/";SUBSTITUE(A1;"x";"/";1))+1;10)*1

Ces formules marchent très bien, cependant j'aimerai les "regrouper" pour que cela fonctionne dans une cellule et ainsi pour tout mon tableur.

Je ne sais pas si cela est possible...

Merci d'avance aux courageux qui essayeront de me venir en aide :)

4 réponses

Messages postés
17689
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
4 850
Bonjour,
je ne saisi pas très bien la démarche, peux tu mettre un exemple de fichier à notre disposition avec tes deux formules que l'on voit s'il te plait.
pour joindre ton fichier exemple avec ce lien

https://www.cjoint.com/

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
26303
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2021
6 127
Bonjour
=SI(GAUCHE(A1;1)=">";DROITE(A1;NBCAR(A1)-1)*1;SI(NB.SI(A1;"*x*");DROITE(A1;NBCAR(A1)-TROUVE("x";A1)-1)*1;A1*1))

crdlmnt
Messages postés
24222
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 novembre 2021
6 974
Bonjour à tous,

autre proposition :
=SI(ESTERREUR(CHERCHE("x<";A1));SUBSTITUE(A1;"<";"");DROITE(A1;NBCAR(A1)-CHERCHE("x<";A1)-1))
et si tu veux en numérique au lieu d'une chaine :
=--SI(ESTERREUR(CHERCHE("x<";A1));SUBSTITUE(A1;"<";"");DROITE(A1;NBCAR(A1)-CHERCHE("x<";A1)-1))
eric
Messages postés
5
Date d'inscription
jeudi 3 avril 2014
Statut
Membre
Dernière intervention
24 avril 2014

Bonjour à tous!

Merci d'avoir pris le temps de répondre à ma question!

Mike-31 : trop tard, on a répondu à ma question :)

Vaucluse : j'ai essayé ta formule, cependant je n'ai pas réussi à la faire fonctionner.. Cela me marque "valeur" à chaque fois..

eriiic : ta premiere formule marche du tonner!! :) Merci beaucoup, cela va me faire gagner un temps précieux! :)

Bonne journée à tous!
Messages postés
24222
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 novembre 2021
6 974
ok, je met en résolu pour toi (en haut vers ton titre, pour la prochaine fois)
eric