Copier cellule à coté

Fermé
Signaler
-
Messages postés
26393
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 janvier 2022
-
Bonjour,

J'aimerais que excel copie la cellule qui est juste en-dessous de chaque cellule qui contient par exemple "10".
Et qui colle la valeur les une en dessous des autres dans une autre feuille.

Mais je n'y arrive pas, même en cherche sur le forum et internet :-(

Merci de votre aide

2 réponses

Messages postés
26393
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 janvier 2022
6 182
Bonjour

peut être une idée ici:
https://www.cjoint.com/?DDykNdFxsE3

crdlmnt

0
Bonjour,

Merci pour ton fichier, peux-tu m'expliquer la formule?

Merci d'avance
0
Messages postés
26393
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 janvier 2022
6 182
Colonne B de feuille BDD

=SI(A1=10;MAX($B$1:B1)+1;"")

la formule détecte si la cellule A de la ligne précédente contient 10 et si oui, ajoute 1 à la valeur maximum au dessus de la cellule où elle se trouve ('le 1° $B$1 est bloqué, pas le second et donc devient MAX($B$1:B2)+1 sur ligne suivante ect...
on obtient donc une valeur incrémentée à chaque fois que la condition est remplie

Colonne A de la feuille EDIT:

=SI(LIGNE()-1>MAX(BDD!B:B);"";INDEX(BDD!A:A;EQUIV(LIGNE()-1;BDD!B:B;0)))

LIGNE() renvoie le N° de ligne sur laquelle se trouve la formule, donc
LIGNE()-1 sur ligne 2 = 1, 2 sur ligne 3 ect...L
si ce numéro obtenu est supèrieur au maxi de la colonne B de BDD, la formule renvoie ""
sinon; le code INDEX:
va chercher dans la colonne A de BDD, la cellule de la ligne où se trouve en B de BDD, la valeur LIGNE()-1

Principe INDEX / EQUIV

=INDEX(champ; ligne, colonne) renvoi la valeur de la cellule au croisement ligne et colonne selon numéros dans le champ
Le N° de colonne n'est utile que si champ en comporte plusieurs.

EQUIV(Valeur;colonne;0) ressort le rang dans le champ de la ligne où se trouve la valeur cherchée et donc dans notre cas le N° de ligne pour INDEX


espèrant avoir été clair
0
Merci pour toutes ces explications et de prendre le temps pour me répondre :-)

Tu trouveras ci-joint un fichier .csv contenant juste deux mail...
http://cjoint.com/data3/3DylNaBcfy5.htm

Je souhaite créer une BDD avec les champs:
Nom:
Prénom
Email:
Adresse
Complément d'adresse
Code postal
Ville
Comment avez-vous connu ......
Message:

Je suis sur qu'il doit y avoir quelque chose de plus simple, mais je t'ai pas donné tous les éléments ;-)
T'en pense quoi?

Merci pour ton aide
0
Messages postés
26393
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 janvier 2022
6 182
Moi je ne peux en penser que ça. Il est fort possible qu'on puisse faire mieux en VBA mais ça n'est pas dans mes compétences!
https://www.cjoint.com/?DDym40LDWuv

crdlmnt
0