Différence entre deux colonnes sous conditions [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
lundi 7 avril 2014
Statut
Membre
Dernière intervention
8 avril 2014
-
 isolaignac -
Bonjour,

J'ai un problème tout simple.
Je dois calculer une marge en faisant la différence entre deux cellules, placées dans deux colonnes (vente - achat).
Je voudrais que la différence ne s'opère que lorsque un montant apparait dans la colonne achat. Ceci afin d'éviter que la colonne "Marge" soit remplie de montants négatifs, qui ne correspondraient en fait qu'à des vente non encore réalisées, et pas vraiment à des marges négatives.

Je vous remercie d'avance pour votre aide.
A voir également:

2 réponses

Messages postés
454
Date d'inscription
mercredi 8 février 2012
Statut
Membre
Dernière intervention
13 août 2015
435
=SI(colonne_achat<>0;vente-achat;"")
Messages postés
3
Date d'inscription
lundi 7 avril 2014
Statut
Membre
Dernière intervention
8 avril 2014

Merci mais je n'y arrive pas encore...
Très bête question mais où dois-je introduire la formule?
Messages postés
9790
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
15 mai 2021
2 112
Bonjour

Un exemple pour illustrer la formule de Benoit A. (salut à toi)
Achat en A2
Vente en B2
Marge en C2
C2=SI(NB(A2);B2-A2;"")
ou bien si tu veux que B2 et A2 soient renseignés
C2=SI(NB(A2:B2)=2;B2-A2;"")
formule à tirer vers le bas

Cdlmnt