Compter le nombre de ligne en fonction d'un département [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
lundi 7 avril 2014
Statut
Membre
Dernière intervention
8 avril 2014
-
Messages postés
5
Date d'inscription
lundi 7 avril 2014
Statut
Membre
Dernière intervention
8 avril 2014
-
Bonjour à tous,

je souhaite compter le nombre de ligne sur mon tableau excel en fonction du département, j'ai essayer la formule =sommeprod((A1:A100="le numéro du département")*1), mais le résultat ne tient pas compte de l'ensemble des codes postaux : 83000, 83100, 83200.... quelqu'un connais une formule qui permet de compter l'ensemble des lignes qui possède le numéro "83" en première position sans tenir compte des 3 derniers chiffres ?

merci de votre aide

9 réponses

Messages postés
9613
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
13 novembre 2020
1 955
Bonjour

à adapter
=SOMMEPROD((GAUCHE(A1:A5;2)="81")*1)

cordialement

ccm81
Messages postés
5
Date d'inscription
lundi 7 avril 2014
Statut
Membre
Dernière intervention
8 avril 2014

Merci de votre aide
Messages postés
9613
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
13 novembre 2020
1 955
De rien
Si c'est fini, peux tu mettre le problème à Résolu (en haut à droite de ton premier message)

Bonne fin de journée
Messages postés
5
Date d'inscription
lundi 7 avril 2014
Statut
Membre
Dernière intervention
8 avril 2014

j'ai essayé cette formule et je n'obtiens pas de résultat, la formule affiche zéro, existe t'il une autre façon de calculer?
Messages postés
9613
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
13 novembre 2020
1 955
As tu bien mis le département entre guillemets
un exemple
https://www.cjoint.com/?3DikUDgOdUX
Messages postés
5
Date d'inscription
lundi 7 avril 2014
Statut
Membre
Dernière intervention
8 avril 2014

j'avais oublié les guillemets, merci, j'ai un autre problème, la formule ne fonctionne pas pour les département qui commence par "0" exemple le 01000 la formule devrait afficher 10 dans mon tableau mais n'affiche que 0

merci de votre aide
Messages postés
9613
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
13 novembre 2020
1 955
Tes n° de départements doivent être certainement être numériques et formatés "00000"
Pour que la formule fonctionne en l'état, tes n° doivent être entrés dans une cellule au format texte
Un exemple
https://www.cjoint.com/?3DilPgp5oZC
Messages postés
2394
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
11 novembre 2020
896
Bonjour,
Pour y remédier:
J'en propose une autre:
=NB.SI(A1:A100;"71*") ou si la valeur cherchée est en J1
=NB.SI(A1:A100;$J$1&"*") mais attention la cellule J1 doit être au format Texte pour éviter des erreurs avec 01,02 ...
Messages postés
5
Date d'inscription
lundi 7 avril 2014
Statut
Membre
Dernière intervention
8 avril 2014

Merci problème résolu, merci de votre aide.