Somme valeurs avec condition dates et échéance

[Résolu/Fermé]
Signaler
Messages postés
24
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
24 juillet 2014
-
Messages postés
24
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
24 juillet 2014
-
Bonjour,


Voici ma situation

J'ai un tableau avec

Colonne a: les dates
Colonne b : valeurs
colonne c : échéance 0 à 3 mois
colonne d : échéance sup à 3 mois

Je voudrais faire un tableau qui me donne la somme des valeurs par mois avec la condition entre 0 à 3 mois

Merci

NB: comment on fait pour mettre en fichier joint le fichier excel avec le message ?


4 réponses

Messages postés
17419
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
29 juillet 2021
4 672
Bonjour,

pour joindre ton fichier sans note confidentielle clic sur ce lien et suivre la procédure, et effectivement se sera plus simple avec ton fichier

https://www.cjoint.com/


1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
26122
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 juillet 2021
5 998
Bonjour
avec par exemple un liste des mois de 1 à 12 de Z1 à Z12
=SOMMEPROD((MOIS($A$1:$A$1000=MOIS(Z1))*($B$1:$B$1000))
pour la cumule des valeurs

et pour 0 à 3 mois, cela dépend de ce que vous avez comme info dans la colonne C
soit un code qui signale l'échéance, par exemple le texte OK
et dans ce cas:
=SOMMEPROD((MOIS($A$1:$A$1000=MOIS(Z1))*($C$1:$C$1000="OK")*($B$1:$B$1000))

ou directement le montant en C et donc
=SOMMEPROD((MOIS($A$1:$A$1000=MOIS(Z1))*($C$1:$C$1000))

Si besoin de complément, pour déposer le fichier:
https://www.cjoint.com/
en revenant ici coller le lien donné par le site
Crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
24
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
24 juillet 2014

j'ai essayé d'appliquer ce que vous m'avez montrer avec cette formule dans le fichier que j'ai mis

=+SOMMEPROD(MOIS(A3:A9219)=MOIS(1)*((C3:C9219)<=91)*(B3:B9219))

colonne a mois
colonne c echeance inf a 3 mois
colonne B valeur

comme résultat j'ai un 0 ...

Merci pour votre aide
Messages postés
26122
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 juillet 2021
5 998
Voyez ici:
https://www.cjoint.com/?DCrlWlHOIgc

pOur info dans la formule le code LIGNE(A1) ne sert qu'à sortir le N° du mois cherché et à l'incrémenter en tirant la formule sur la hauteur du tabLEau 1 pour A1 2 pour A2 ect

crdlmnt

Errare humanum est, perseverare diabolicum
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
24
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
24 juillet 2014

Merci beaucoup !
Messages postés
26122
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 juillet 2021
5 998
Pas de quoi, je passe le sujet en résolu
Bonne route
crdlmnt
Messages postés
24
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
24 juillet 2014

J'aurais besoin d'un dernier coup de pouce concernant le même sujet

J'ai utilisé les formules précédentes cela marche très bien pour l'année 2014 mais pour l'année 2013 j'ai un écart que je n'arrive à trouver ( du coup je me dit que j'ai peut être fait une gaffe au niveau des formules )

Voici le fichier

https://www.cjoint.com/?DCrpieJxs7n

Merci
Messages postés
24
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
24 juillet 2014

Voici le lien

https://www.cjoint.com/?DCrlBPg3HE3

les échéances sont en nombre de jours
Merci d'avance