Fonction SOMMEPROD [Résolu/Fermé]

Signaler
Messages postés
159
Date d'inscription
mercredi 29 décembre 2010
Statut
Membre
Dernière intervention
26 février 2015
-
Messages postés
159
Date d'inscription
mercredi 29 décembre 2010
Statut
Membre
Dernière intervention
26 février 2015
-
Bonjour à tous,

je souhaite réaliser un tableau d'avance retard sur le chiffre d'affaire de la société pour laquelle je travail

j'ai crée un tableau sous excel qui se présente de manière très simple : Noms des clients sur la premiere colonne et mois de l'année sur la premier ligne.

Chaque fin de mois je récupère les chiffres de mes ventes classé par : clients, référence de produit, montant expédiée, quantité, date d'expedition..ect

c'est exactement ici que tous cela devient compliqué : Je souhaiterai que mon tableau d'avance retard se remplisse automatiquement. Mes clients se font livrer des pièces tous les mois en fonction de leurs besoin.

Chaque nom de client est rattaché à un numero client qui lui est propre

j'ai déjà élaborer un tableau croisée dynamique, mais cette outils ne me donne pas une analyse mois par mois.

J'ai pensé dans un premier temps à la fonction SOMMEPROD :

=SOMMEPROD((si colonne A=référence client)*(si colonne N=1(1pour janvier))*(colonne I=Fais moi la somme du CA))

PS : Les deux tableaux sont sur des onglets séparés

Merci d'avances pour vos réponses...

3 réponses

Messages postés
17089
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
11 avril 2021
10 309
Bonjour,

Tout n'est pas très clair...
Peux tu donner un exemple allégé de ton fichier pour qu'on se rende mieux compte ?
https://www.cjoint.com/

A priori, je dirais qu'un tableau croisé est une bonne solution. Un TCD te permet tout à fait de faire des regroupements par moi, à l'aide de la fonction Grouper.

Merci aussi de préciser ta version d'Excel.

m@rina
Messages postés
159
Date d'inscription
mercredi 29 décembre 2010
Statut
Membre
Dernière intervention
26 février 2015
6
Bonjour m@rina

Tout d'abord merci pour avoir pris le temps de me répondre.

Tu trouveras ci dessous le fichier excel que j'ai un peu modifié (pour des raisons pro).

https://dl.dropboxusercontent.com/u/51908885/Fichier%20type.xlsx

je ne connais pas toutes les fonctions d'excel mais il doit probablement exister une solution pour que le tableau "avance retard" puisse automatiquement faire les sommes des "montant exp" )de l'onglet CA) relatif à chaque client.

Qu'en penses tu ?

Merci d'avance pour ton aide
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Bonjour

Marina a surement raison (salut @M, content de te retrouver de temps en temps chez Excel)

toutefois pour éclaircir SOMMEPROD:

=SOMMEPROD((ChampA=refA)*(ChamB=RefB)*(Champ à sommer))

SOMMEPROD ne fonctionne pas dans ce cas avec des adresses uniquement définies par les colonnes (type A:A) il faut inclure les N° de lignes (Type A1:A1000) avec bien entendu la même hauteur de champ dans tous les items.


crdlmnt


Errare humanum est, perseverare diabolicum
Messages postés
159
Date d'inscription
mercredi 29 décembre 2010
Statut
Membre
Dernière intervention
26 février 2015
6
Bonjour Vaucluse

Merci pour ta réponse. Effectivement je comprends mieux la fonction SOMMEPROD.

les deux critères que je dois distinguer sont bien le mois et le compte client.

Il me reste donc l'option détendre les champs au maximum pour automatiser les calculs (Usine à gaz pour le coup)

J'imagine que Excel à prévu une alternative mais je cherche encore.

As tu une idée ?

le liens vers mon fichier et dans ma réponse à marine.

Merci d'avance pour ton aide.
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Bonjour
Ci joint modèle avec quelques solutions:
https://www.cjoint.com/c/DBfh0ZoO74Q
a suivre?
crdlmnt
Messages postés
159
Date d'inscription
mercredi 29 décembre 2010
Statut
Membre
Dernière intervention
26 février 2015
6
Bonjour Vaucluse

Merci pour ton aide.

Je vais essayer de comprendre la solution que tu m'apportes.

Je reviens vers toi si je bloque.

Avec mes remerciements
Messages postés
9935
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
16 mars 2021
1 132
Bonjour,
Excusez-moi pour le dérangement, et bonne chance.
Salutations.
Le Pingou
Messages postés
159
Date d'inscription
mercredi 29 décembre 2010
Statut
Membre
Dernière intervention
26 février 2015
6
Merci pour ta réponse Vaucluse, j'ai adapté ta formule! Parfais.

Je cloture et valide.
Messages postés
9935
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
16 mars 2021
1 132
Bonjour,
Et si vous mettiez le résultat que vous voulez obtenir par rapport aux données de la feuille [CA] ce serait plus compréhensible.... !

Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Salut le Pingou
Ben alors? j'espère que je ne t'ai pas vexé?.. j'ai juste continué ce que j'avais commencé.
Bien amicalement et sans rancune?
Au plaisir
Messages postés
9935
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
16 mars 2021
1 132
Bonjour,
Non, non pas toi, bien au contraire.
Amicales salutations
Le pingou