Extraction et renvoi vers feuille

[Résolu/Fermé]
Signaler
Messages postés
394
Date d'inscription
mardi 5 octobre 2010
Statut
Membre
Dernière intervention
21 novembre 2020
-
Messages postés
394
Date d'inscription
mardi 5 octobre 2010
Statut
Membre
Dernière intervention
21 novembre 2020
-
Hello tout le monde !

Encore une colle pour moi ...
J'ai essayé des tas de solutions sans succès:
J'ai un fichier Excel dont la page de garde rappelle en colonne A les titres de toutes mes feuilles.
Donc en colonne A j'ai :
Client1
Client2
Client3
...

Mes feuilles s'appellent aussi :
Feuille1 : Client1, Feuille 2 : Client2, ...

Problème : Sur la page de garde, en B$X j'aimerai obtenir le résultat de la cellule F5 de la feuille dont le nom est inscrit en A$X.
Exemple : sur la feuille Client3 en F5 j'ai "Bon client" : comment faire pour qu'en Page de garde\B3 je récupère "Bon Client".

J'ai essayé de saisir en B3 : =TEXTE(A3;0)!F5) sans succès.

Un fichier exemple sur : https://www.cjoint.com/?CJiv6SJ8Xmg

Un grand merci d'avance.

3 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 512
Bonjour touroul,

=INDIRECT("'"&A3&"'!F5")
Attention, il y a guillemet et apostrophe dans le code pour gérer le nom de feuille.

Bonne soirée.
Messages postés
13097
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 septembre 2021
2 247
Bonsoir

Proceder ainsi
https://www.cjoint.com/?0Jiws0PPFOQ

Cdlmnt
Messages postés
394
Date d'inscription
mardi 5 octobre 2010
Statut
Membre
Dernière intervention
21 novembre 2020
12
Vous êtes des Dieux !

Ca marche au poil et moi j'ai encore appris quelque chose.

Mille mercis et bonne soirée à vous deux !

Touroul