Voir le texte ds cellule, mais pour les formules valeur 0

Résolu/Fermé
John-F_Q - 31 juil. 2013 à 18:18
Yrmouf
Messages postés
128
Date d'inscription
samedi 4 août 2012
Statut
Membre
Dernière intervention
22 septembre 2020
- 1 août 2013 à 11:21
Bonjour, possible résolutioneur de problème!

J'ai une formule dans excel et quand je rencontre les cellules contenant du texte j'obtiens ##### comme réponse.

Est-ce qu'il y a un moyen de voir le texte dans la cellule, mais que pour le bien de ma formule excel considère se texte comme étant zéro?

Merci d'avance a toutes et a tous!



3 réponses

PHILOU10120
Messages postés
5965
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
19 mai 2022
709
31 juil. 2013 à 19:27
Bonjour

Avec un contrôle de texte

Exemple pour la cellule A1 contenant "Paul" le résultat sera Paul autrement votre calcul,(A1+x)

=SI(ESTTEXTE(A1);A1;"votre opération")
1
Yrmouf
Messages postés
128
Date d'inscription
samedi 4 août 2012
Statut
Membre
Dernière intervention
22 septembre 2020
4
31 juil. 2013 à 19:08
Bonsoir,

Avez-vous essayer d'agrandir la taille de colonne? Ces # apparaissent quand le texte ne peut s'afficher en entier dans une cellule.
0
Je me suis peut-être mal exprimer tout est visible par contre j'ai pour une bonne partie de ma colone c'est des chiffres, donc le calcul se fait bien, mais quand les formules rencontres du texte les réponses au formule sont ######, et c'est pour ça que je voudrais que le texte qui "Aucun" sois considérer comme zéro pour que la réponse a ma formule donne aussi zéro.
0
Yrmouf
Messages postés
128
Date d'inscription
samedi 4 août 2012
Statut
Membre
Dernière intervention
22 septembre 2020
4
1 août 2013 à 11:21
Au temps pour moi! Mais je viens de voir que Philou10120 vient de donner la réponse, bonne journée :)
0
PHILOU10120
Messages postés
5965
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
19 mai 2022
709
31 juil. 2013 à 20:00
Voici une idée

=SI(OU(F10="";G10="");"";MOD(G10-F10;1))
0