Colorier une cellule sous condition

Fermé
dan33 - 11 juin 2013 à 09:37
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 - 11 juin 2013 à 11:39
Bonjour,

je voudrai colorier la cellule i2 en vert, si les cellules de B2 à H2 comportent
le nom "oui",
même si cela parrait extrémenet facile, pour moi, complétement néophyte en la matière c'est compliqué, quelqu'un peut-il m'aider, merci d'avance à tous


5 réponses

Bonjour,

Tu travaille sur quelle version d'Excel ?

2003, 2007, 2010 ou 2013
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
11 juin 2013 à 09:59
Bonjour
mise en forme conditionnelle
sélectionner I2
Sous excel avant 2007:
barre d'outil / Format / Mise en forme conditionnelle et dans la fenêtre choisir formule
à partir de 2007
Ruban / Onglet accueil / Icone Mise en forme conditionnelle / Nouvelle régle et "utiliser une formule ..."
Entre la formule:
si vous voulez que toutes les cellules de B à H contiennent un oui:
=NB.SI($B2:$H2;"oui")=8)
si vous voulez détecter un oui seulement:
=NB.SI($B2:$H2;"oui")
cliquer sur format
choisir le format
OK / OK
pour appliquer ligne par ligne sur une hauteur en I, sélectionner la hauteur utile de I et entrer la formule correspondante à la première cellule de la sélection.
crdlmnt
0
Maxxikilla Messages postés 40 Date d'inscription mardi 4 juin 2013 Statut Membre Dernière intervention 23 juillet 2013
Modifié par Maxxikilla le 11/06/2013 à 10:03
Bonjour,

Si tu souhaites le réaliser à l'aide de macro,voici comment tu peux procéder.
i représente to nombre de colonnes.
j représente le nombre de fois ou tu aura oui dans une case.
la boucle for parcoure de B2 à H2
si tu a 7 oui, alors, ca colorie i2 en vert :)

Sub ColorierSiOuiB2H2()

Sheets("ici le nom de ta feuille").Activate

'i le nombre de colonnes, j ton compteur
Dim i, j As Integer
j = 0

For i = 2 To 8

If Cells(2, i) = "oui" Then
j = j + 1
End If

Next i

MsgBox (j)

If j = 7 Then
Cells(2, 9).Interior.Color = vbGreen
End If

End Sub


Si tu as des questions, n'hésites pas
0
Re Bonjour,

Je te propose une alternative pour arriver à tes fins :

Insert une colonne entre H et I

Copie la formule si dessous en fonction si ton Excel est en anglais ou français
=IF(AND(B2="oui";C2="oui";D2="oui";E2="oui";F2="oui";G2="oui";H2="oui");"X";"")

ou

=SI(ET(B2="oui";C2="oui";D2="oui";E2="oui";F2="oui";G2="oui";H2="oui");"X";"")

Puis en J2 dans conditionnal formation selectionne formule et saisie la formule si dessous :

=$J$2

Sélectionne le format dans lequel tu veux que ta cellule soit (fond vert dans ton exemple)

Puis valide.

Si tu ne veux masquer la colonne I fait un clique droite puis "Masquer" ou "Hide" selon les versions.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
11 juin 2013 à 11:39
Bonjour tous
Max... Weapon..
... deux réponses bien complexes pour une solution déjà standardisée dans Excel, non?
crdlmnt
0