Apache2 debian

Résolu
bonjour, je suis nouveau sur le forum et suis en 2eme année bts info.
J''ai un probleme que je n'arrivee pas a résoudre. J'installe mon serveur debian à l'aide de ce tuto, je fais tout presque pareil: http://olange.developpez.com/article...serveur-dedie/

Le probleme survient lors du lien symbolique ln -s /etc/apache2/sites-available/test /etc/apache2/sites-enabled/test car quand je le supprime le serveur marche et lorque je le met en place au redemmarge d'apache j'obtient :
Forcing reload of web server (apache2)...httpd (no pid file) not running
failed!
Mon pc plante et sans le lien je ne peut faire localhost/~user
Si jamais vous avez une idée merci de me sauver !
Configuration: Linux Debian
Epiphany 2.14

9 réponses

  1. fichier sites avalable
    default:

    NameVirtualHost *
    <VirtualHost *>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    # This directive allows us to have apache2's default start page
    # in /apache2-default/, but still have / go to the right place
    RedirectMatch ^/$ /apache2-default/
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined
    ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

    </VirtualHost>

    test1.com

    <VirtualHost *>
    ServerAdmin postmaster@test1.com
    ServerName www.test1.com
    ServerAlias test1.com *.test1.com
    DocumentRoot /home/test1/public_html/
    <Directory /home/test1/public_html/>
    Options -Indexes FollowSymLinks MultiViews
    AllowOverride All
    </Directory>
    ErrorLog /home/test1/logs/error.log
    LogLevel warn
    CustomLog /home/test1/logs/access.log combined
    ServerSignature Off
    </VirtualHost>
    1
    1. Merci d'essayer de m aider car je fais le serveur pour une entreprise et il vaut mieux que ça tourne bientôt!

      En faites j'ai réinstaller ma debian et la plus de problème en faisant a la lettre le fameux tuto ! Si ce n'est qu'en faisant http://xxx.xxx.xxx.xxx/~test1 j'arrive au célèbre :
      Not Found
      The requested URL /~intranet was not found on this server.

      Enfin bon je suis habituer a 2003 serveur mais linux cest sympa quand même
      0
      1. Modérateur
        Salut,

        Ton utilisateur "test1" existe bien au moins ?
        Le dossier "public_html" de ce même utilisateur existe-t'il aussi ?

        Affiche-nous ton ficher de configuration s'il te plaît (s'il est trop important, colle-le sur Cjoint).
        0
        1. Modérateur
          Ben je vois pas où ça pourrait coincer !!??

          T'as bien redémarré ton serveur après les modifs ?

          Est-ce que sans VirtualHost le site était accessible ?
          0
          1. merci de ton aide. J'ai trouvé la solution :
            etc/apache2/mods-available/userdir.load vers /etc/apache2/mods-enable/userdir.load et /etc/apache2/mods-available/userdir.conf vers /etc/apache2/mods-enable/userdir.conf

            et ça marche !

            a bientot ptete pr de nouvelle zaventure je vais installer ftp et phenix.
            0
            1. Bonjour,
              je suis exactement dans la même situation sauf que pour moi la technique:

              /etc/apache2/mods-available/userdir.load vers /etc/apache2/mods-enabled/userdir.load
              et
              /etc/apache2/mods-available/userdir.conf vers /etc/apache2/mods-enabled/userdir.conf


              ne fonctionne pas j'ai toujours ce problème d'apache2 qui ne veux pas démarrer.

              pour faire ces liens symboliques j'ai fait:
              ln -s /etc/apache2/mods-available/userdir.load /etc/apache2/mods-enabled/userdir.load
              ln -s /etc/apache2/mods-available/userdir.conf /etc/apache2/mods-enabled/userdir.conf

              C'est bien ça qu'il faut faire?
              Si oui quelqu'un autait-il une idée pour m'aider à me débarasser de ce problème? merci d'avance!
              0
          2. Modérateur
            De rien, mais j'y suis pour rien ;-))
            0
            1. its résolu!
              0
              1. bien joué moi aussi je galérais

                En tout cas merci
                0
              2. @rhilluLe probléme de base n'en n'est pas un c'est juste que sous Debian ou Ubuntu par exemple tu dois tapper "sudo" avant pour te mettre en root.

                Et puis c'est tout ;)

                nico
                0