Utilisation de min ou max avec critère

Fermé
Signaler
Messages postés
9
Date d'inscription
jeudi 29 novembre 2012
Statut
Membre
Dernière intervention
2 juin 2013
-
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
-
bonjour Messieurs,

j'ai une préoccupation, j'aimerai utiliser la fonction min ou max avec des critères, par exemple, j'ai une valeur F2 sur la colonne F dont j'aimerai avoir le min ou le max de ses correspondances sur la colonne D, et celà pour toute les valeur sur la colonne F.

6 réponses

Messages postés
435
Date d'inscription
mardi 14 mai 2013
Statut
Membre
Dernière intervention
24 mars 2021
25
Bonjour,

Je me permets de répondre même si je suis une mademoiselle...

Est-ce que tu peux mettre un fichier exemple, je ne comprends pas bien ce que tu veux faire.
Messages postés
9
Date d'inscription
jeudi 29 novembre 2012
Statut
Membre
Dernière intervention
2 juin 2013

slt Mademoiselle,

voici le lien du fichier joint : https://www.cjoint.com/?3Fcrls5Cw5x

tu verra sur la colonne A, des numéron qui se repette, ce que j'aimerai c'est pour tous le numéro qui se repète sur la colonne A, avoir le min ou le max des leur donnée sur la colonne F.

par ex. A2 se repete 58 fois sur la colonne A, j'aimerai avoir le min ou le max correspondant sur la colonnes E (des tous les 58 lignes).
et faire de même pour toutes les céllules de A.

jespère que j'ai été assez claire...

merci d'avance pour ta réponse!!! :)
Messages postés
435
Date d'inscription
mardi 14 mai 2013
Statut
Membre
Dernière intervention
24 mars 2021
25
J'ai fait quelques essais, mais pour l'instant je n'y arrive pas. Mais je me demande si tu ne pourrais pas simplement faire un tri par Numéro de référence, puis par date. Tu vas pouvoir voir le maximum de chacun. Et si tu veux vraiment voir la date max de chaque ligne tu peux mettre cette formule :

=RECHERCHEV(A147;A147:E454;MAX(5))

Mais elle fonctionne juste si tes données sont triées.
Messages postés
9
Date d'inscription
jeudi 29 novembre 2012
Statut
Membre
Dernière intervention
2 juin 2013

Ok, merci!

je crois ke jvais m'en contenter...
Messages postés
16537
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
25 novembre 2021
3 249
Bonjour vous 2

https://www.cjoint.com/?3Fcsqwag4M8

pour faire la colonne des ref sans doublon
copier la colonne A en colonneI (ou autre)
puis données- supprimer les doublons

en J2
=MIN(SI(A$2:A$658=I2;E$2:E$658))
en K2
=MAX(SI(A$2:A$658=I2;E$2:E$658))

Formules matricielles à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule; Excel encadre alors automatiquement la formule par des {}

tirer vers le bas
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
889
Salut le Forum

Formule matricielle à valider par CTRL + SHIFT + ENTER et recopier vers le bas.

Le MAX (Formule EN F2)
=MAX(SI($A$2:$A$658=A2;$E$2:$E$658;""))
Le MIN (Formule en G2)
=MIN(SI($A$2:$A$658=A2;$E$2:$E$658;""))
Mytå

Merci de donner suite à votre question, nous ne sommes pas des robots...
« Si le déboguage est l'art d'enlever les bogues, alors la programmation doit être l'art de les créer. »