Fonction SI dans Exel

Résolu/Fermé
mcjf - 25 mai 2013 à 05:52
mcjf
Messages postés
49
Date d'inscription
mardi 13 novembre 2012
Statut
Membre
Dernière intervention
24 mai 2020
- 27 mai 2013 à 14:28
Bonjour,

Je bute sur l'écriture d'une fonction SI dans exel.


J'ai inscrit une fonction SI dans deux cellules D13 et E13

=SI(D13>0;D13*2,3;"") et le résultat s'inscrit correctement

Dans une autre cellule, I13, je veux faire le total de quatre cellules dont les deux précédentes

Si la valeur d'au moins une des 4 cellules est supérieure à 0, le total s'affiche dans I13
sinon I13 doit rester vide

J'ai écrit la fonction suivante dans I13

=SI(OU(C13>0;D13>0;F13>0;H13>0);SOMME(C13+E13+G13+H13);"")

mais j'ai alors en résultat #VALEUR!

et impossible de trouver l'erreur

Si quelqu'un peut m'aider à corriger ma formule

Je vous remercie

27 réponses

mcjf
Messages postés
49
Date d'inscription
mardi 13 novembre 2012
Statut
Membre
Dernière intervention
24 mai 2020

27 mai 2013 à 11:59
Je veux bien, mais comment on fait et je l'envoie où
0
Mike-31
Messages postés
17941
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 mai 2022
4 939
27 mai 2013 à 12:55
Re,

clic sur ce lien, puis sur parcourir pour sélectionner ton fichier, puis créer le lien et colle le lien généré dans un post
0
PapyLuc51
Messages postés
3635
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 mai 2022
1 092
27 mai 2013 à 13:06
Bonjour,

Le lien n'apparaît pas dans le message de Mike-31

le voici

https://www.cjoint.com/

Cordialement
0
Mike-31
Messages postés
17941
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 mai 2022
4 939
Modifié par Mike-31 le 27/05/2013 à 13:28
Re,

Oui j'ai peut être omis de le coller mais bon, en I13 colle cette formule à la place de celle existante et incrémente vers le bas


=SIERREUR(SOMME(C13+E13+G13+H13);"")

ou même comme cela sans l'opérateur

=SIERREUR(SOMME(C13;E13;G13:H13);"")

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
mcjf
Messages postés
49
Date d'inscription
mardi 13 novembre 2012
Statut
Membre
Dernière intervention
24 mai 2020

27 mai 2013 à 13:58
J'ai bien rentré la formule que tu me proposes,

J'ai le total qui s'affiche en I mais seulement lorsque j'entre une valeur en F, et j'ai bien le total des 4 colonnes qui est pris en compte

C'est incompréhensible
0
Mike-31
Messages postés
17941
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 mai 2022
4 939
27 mai 2013 à 14:15
Re,


=SI(ET(C13<>"";D13<>"";F13<>"";H13<>"");SOMME(C13;E13;G13:H13);"")

ou comme cela si on teste les cellules résultantes
=SI(ET(E13<>"";G13<>"";H13<>"");SOMME(C13;E13;G13:H13);"")
0
mcjf
Messages postés
49
Date d'inscription
mardi 13 novembre 2012
Statut
Membre
Dernière intervention
24 mai 2020

27 mai 2013 à 14:28
Super,

ça marche, j'ai utilisé la première formule en remplaçant "ET" par "OU",

Sans cela le total ne s'affiche que lorsque D contient une valeur


Encore merci pour ton aide
0