Fonctions SI/ET/OU

Résolu/Fermé
Plipla Messages postés 1 Date d'inscription mardi 21 mai 2013 Statut Membre Dernière intervention 21 mai 2013 - 21 mai 2013 à 08:38
 Plipla - 21 mai 2013 à 09:44
Bonjour,

Je crée un indicateur de performance sur excel. Il me permet de vérifier le respect des délais de nos fournisseurs. Pour certains d'entre eux nous avons plusieurs délais contractuels en fonction des articles.
J'ai identifié ces articles par des codes allant de 1 à 4.
J'ai ensuite calculé le temps entre date de commande et date de livraison.

Je souhaite maintenant marquer dans une dernière colonne: "Délai OK" ou "Délai NON OK". Pour cela je dois mixer si/et/ou.
Je galère.

Je veux dire pour le premier tableau :

si A1 = 1et que b1<=11 alors "Délai OK" sinon "Délai NON OK" ou si a1 = 2 et que b1 <= 15 alors "délai OK", sinon "Délai NON OK".

Pour le second tableau :
si a1 = 1 et que b1<=30 alors "délai ok", sinon "délai non ok" ou si a1=2 et que b1 <=5 alors "délai ok", sinon "délai non ok" ou si a1=3 et que b1 <=15 alors "délai ok" sinon "délai non ok" ou si a1=4 et b1<=10 alors "délai ok" sinon "délai non ok".

Ces deux formules m'empêchent de terminer mon indicateur.


Je vous remercie d'avance pour votre aide.

Plipla :)

1 réponse

gbinforme Messages postés 14939 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 647
21 mai 2013 à 09:16
Bonjour,

Pour ton second tableau, tu peux mettre :

=SI(B1<=CHOISIR(A1;30;5;15;10);"délai ok";"délai non ok")

et pour le premier en plus simple :

=SI(B1<=CHOISIR(A1;11;15);"délai ok";"délai non ok")
0
Whaouuh ! Merci beaucoup ! Je ne comprend pas du tout comment cela fonctionne mais ça fonctionne alors merci mille fois, pour moi, mon mémoire et mon boss !
0
gbinforme Messages postés 14939 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 647
21 mai 2013 à 09:37
Je ne comprend pas du tout comment cela fonctionne

La fonction CHOISIR sélectionne dans les paramètres celui dont le rang est égal au premier :
dans ton cas, si dans A1 tu as 3, tu compares B1 au 4ième de la liste 15.
Cela permet d'écrire une condition SI avec plusieurs paramètres en un seul résultat, vrai ou faux.
0
Ok, c'est clair. Merci encore.
0