=SI(ESTNA(RECHERCHEV me donne une réponse FAUX [Résolu/Fermé]

Signaler
-
 Raph333 -
Bonjour à tous et toute,

J'ai découvert récemment cette fabuleuse formule RECHERCHEV,
comme beaucoup j'ai par la suite voulu supprimer ce fameux N/A en utilisant la formule =SI(ESTNA(RECHERCHEV .... et ça marche le N/A disparaît, mais du cou quand je tape ma "Valeur cherchée" il ne me trouve rien et m'indique " FAUX "

Voici La formule que j'utilise avec les N/A affichée

=RECHERCHEV(D2;'STOCK COMPLET'!A:B;2;0)

La tout Fonctionne mes le N/A apparaît

Voici la formule que j'utilise pour enlever le N/A

=SI(ESTNA(RECHERCHEV(D2;'STOCK COMPLET'!A:B;2));"").

D'avance merci à tous pour vos réponse.

Raphaël



3 réponses

Messages postés
17140
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 juillet 2020
4 143
Salut,

la formule de base est
=RECHERCHEV(D2;'STOCK COMPLET'!A1:B20;2;0)

Il faut saisir les bornes de la matrice (zone de recherche) ex. A1:D50 ensuite tu l'avais fait la colonne de recherche et en fin la condition faux ou 0

mais lorsque tu écris la formule sur une feuille différente il est préférable de nommer la matrice (la zone de recherche) exemple la plage A1:D50 de la feuille STOCK COMPLET tu la nommes exemple list

la formule devient

=RECHERCHEV(D2;list;2;0

et pour gérer l'erreur et donc l'affichage #N/A tu écris ta formule comme cela

=SIERREUR(RECHERCHEV(D2;list;2;0);"")
7
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57892 internautes nous ont dit merci ce mois-ci

Messages postés
12992
Date d'inscription
dimanche 18 novembre 2012
Statut
Membre
Dernière intervention
2 février 2015
1 314
Bonsoir,

dans ta seconde formule tu teste si le résultat est NA
Si le résultat renvoie un NA alors tu n'affiche rien, dans le second cas tu n'as rien mis, donc il te renvois FAUX ce qui est normal

la condition fonctionne ainsi

SI(condition;action si vrai; action si faux)

dans ta condition ESTNA tu teste le resultat de ta RECHERCHEV(....)

l'action si vrai est de ne rien afficher
Que fais tu si le résultat est Faux ? rien pour l'instant
Bonjour à tout les deux,

Super merci pour vos réponse, j'ai opter pour la 2ème problème réglé,

Grand merci =)

Excellente journée,

Raphaël