Feuille de statisque sur des nombres

[Fermé]
Signaler
Messages postés
497
Date d'inscription
dimanche 25 décembre 2011
Statut
Membre
Dernière intervention
9 octobre 2021
-
Messages postés
497
Date d'inscription
dimanche 25 décembre 2011
Statut
Membre
Dernière intervention
9 octobre 2021
-
Bonjour,

J'ai fait plusieurs series de nombres sous cette forme par exemple 5 14 24 48 50 prenant exactement une serie par cellule.
J'aimerai savoir combien de fois un nombre ou un chiffre est present au total dans toutes les series sous la forme de graphique à baton par exemple.
j'aimerai avoir ces informations:
Le nombre de fois ou le numero est apparue dans une serie et le pourcentage pour chacun des numeros

Je sais pas si j'etais claire est ce que quelqu'un peut m'expliquer comment faire ?

Merci pour votre aide


5 réponses

Messages postés
13127
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
25 octobre 2021
2 274
Bonsoir

Un exemple avec 3 séries de 5 chiffres allant jusqu'à 25
https://www.cjoint.com/?3Ecv7LDpCum

Est ce bien ce que tu cherches à obtenir?

Cdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
497
Date d'inscription
dimanche 25 décembre 2011
Statut
Membre
Dernière intervention
9 octobre 2021
1
J'ai essayé de m'inspirer de ton travail mais ça ne marche pas.
Je t'envoie une copie de mon travail que tu arrives a t'imagines clairement les choses.

Voilà mon travaille https://www.cjoint.com/c/CEtqKhAq9qb
Messages postés
13127
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
25 octobre 2021
2 274
Bonjour Stell

J'ai adapté ma méthode à ton fichier avec un onglet pour calcul des données et un onglet pour le graphique

https://www.cjoint.com/?0EurfS1RZpL

Cdlmnt
Messages postés
497
Date d'inscription
dimanche 25 décembre 2011
Statut
Membre
Dernière intervention
9 octobre 2021
1
Merci ton fichier est tres claire
Messages postés
497
Date d'inscription
dimanche 25 décembre 2011
Statut
Membre
Dernière intervention
9 octobre 2021
1
Excuse moi de te poser une autre question mais y a un truc qui ne fonctionne pas. J'aimerai associer plusieurs cellules qui se trouvent dans différentes feuilles avec la formule que tu m'as donné =NB.SI('feuille1'!C2:G44;A2)

J'ai essayé comme ça
=NB.SI('feuille1'!C2:G44;A2)('feuille2'!C2:G44;A2)('feuille3'!C2:G44;A2)
ou
=NB.SI('feuille1'!C2:G44;A2!'feuille2'!C2:G44;A2!'feuille3'!C2:G44;A2)
et d'autres trucs mais ça ne fonctionne pas

C'est possbile de m'expliqué ?

Merci pour ton aide
Messages postés
497
Date d'inscription
dimanche 25 décembre 2011
Statut
Membre
Dernière intervention
9 octobre 2021
1
REPONSE : =NB.SI('feuille1'!C2:G44;A2)+NB.SI('feuille2'!C2:G44;A2)+NB.SI('feuille3'!C2:G44;A2)
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 657
Bonjour,

Une formule pour connaitre le nombre de fois ou apparait le chiffre 4 dans la cellule B7, par exemple, est :
=NBCAR(B7)-NBCAR(SUBSTITUE(B7;4;""))

Maintenant, à toi à te créer tes tableaux de résultats, grâce à cette formule, et à créer tes graphiques à partir de ces tableaux.
Messages postés
26243
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 octobre 2021
6 093
Bonjour
*assez compliqué en fait
L'idée de Pijaku est bonne, mais présente un inconvénient, c'est de compter tous les 4 sans s'occuper de savoir s'ils sont solitaires ou s'ils appartiennent à un nombre... et comme votre exemple présente des chiffres seuls et des nombres composés, essayez peut être la formule de Pijaku, mais en complétant avec deux blancs pour spécifier la valeur cherché, soit:
=NBCAR(B7)-NBCAR(SUBSTITUE(B7;" 4 ";""))

Mais ça reste encore aléatoire s'il n'y a pas de blanc en fin et début de liste. dans ce cas on complète:
=NBCAR(B7)-NBCAR(SUBSTITUE(" "&B7&" ";" 4 ";""))

Crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
497
Date d'inscription
dimanche 25 décembre 2011
Statut
Membre
Dernière intervention
9 octobre 2021
1
pardonner moi pour ma réactivité catastrophique mais je n'ai plus internet et je suis en deplacement.
mais j'ai pris note de vos commentaires et j'appliquerai cela a mon retour.

En faite pour etre plus claire voilà comment mon fichier est representé
En B2 14 17 46 49 53
En B3 3 9 12 45 51

Tout les nombres de la série sont séparé par un espace et par ordre croissant.

Dans une series de chiffre il ne peut pas y avoir 2 fois le même nombre, et on peut aller jusqu'à 70.

Par contre ce que je veux faire, c'est faire des statiques sur ces 70 nombres en memes temps. Je veux connaitre le pourcentages de présence de chacun des nombres à partir de toutes les series en pourcentage, en graphique par exemple.

Je sais pas si j'etais claire dans mes explications, en tout cas merci
Messages postés
2497
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
19 octobre 2021
1 001
Bonjour,
Juste une proposition simpliste pour réamorcer la pompe:
https://www.cjoint.com/?3Etr7PO8KYs
Messages postés
10161
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
23 octobre 2021
2 232
Bonjour

J'avais tenté quelque chose à l'époque, je ne sais pas si ça correspond car le fichier de Stell-91 n'est pas au format excel 2003, mais bon, on ne sait jamais, comme tontong (salut à toi en passant) je ré-amorce !!
https://www.cjoint.com/?3EupAWGQnzZ

Bonne journée à tous
Messages postés
2497
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
19 octobre 2021
1 001
Bonjour,
Le fichier de ccm81,( même sans demandeur on peut en parler entre nous ;-)), me montre que j'ai oublié le graphique et comme il pleut sur la saint Raf..rin:
https://www.cjoint.com/?3EuqgkMf1Py