Remplissage automatique sous condition

[Résolu/Fermé]
Signaler
Messages postés
3
Date d'inscription
mercredi 24 avril 2013
Statut
Membre
Dernière intervention
24 avril 2013
-
Messages postés
3
Date d'inscription
mercredi 24 avril 2013
Statut
Membre
Dernière intervention
24 avril 2013
-
Bonjour,

Après avoir passé des heures en essayant de trouver une solution, j'abandonne et vient solliciter de l'aide.
Alors voilà je voudrais pouvoir remplir un tableau suivant des données externes (la source de mes données se trouve sur le même classeur excel mais sur une autre feuille). Explications, je dois pouvoir remplir des cellules en fonction de ce que je vais mettre dans une. Donc si par exemple en J5 je met 41, je voudrais qu'en C3 apparaisse automatiquement le nom d'une personne et en J3 apparaisse son prénom. Si en J5 je met 60, c'est une autre personne qui apparaisse et ainsi de suite.
J'espère avoir été clair dans mes explications et que ce soit réalisable.
Merci par avance de pouvoir prendre du temps.
Frédéric

5 réponses

Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 389
Salut,

peut-être avec la fonction RECHERVHEV mais faut savoir comment est monté ton fichier.
Tu pourrais envoyer ton fichier en le déposant sur cjoint.com et en collant le lien généré ici.

Prends soins d'enlever des informations personnelles
Messages postés
5608
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 septembre 2021
642
Bonjour

En C3 mettre cette formule

=RECHERCHEV($J$5;Feuil2!$A$10:$G$30;2;FAUX)

Feuille2 est le nom de la feuille ou sont stocké les informations Nom, Prénom, ...
A10:G30 le champ dans lequel il faut chercher, la première colonne A dans mon exemple comporte les numéro, 41, et 60 .... et ainsi de suite
2 pour aller chercher l'information dans la 2ème colonne nom

En J3 mettre cette formule

=RECHERCHEV($J$5;Feuil2!$A$10:$G$30;3;FAUX)

3 pour aller chercher l'information dans la 3ème colonne prénom

Indexé sur le même champ que la première
le champ première colonne numéro
2ème colonne le nom
3ème colonne le prénom
et les autres informations exemple rue, code postal, ville dans les colonne suivante
Messages postés
3
Date d'inscription
mercredi 24 avril 2013
Statut
Membre
Dernière intervention
24 avril 2013

Bonjour,

Merci d'avoir pris du temps pour me répondre.
J'ai mis en application l'astuce de PHILOU10120 ça marche, il y a juste un petit soucis c'est que si je ne remplis pas la cellule J5 maintenant ça m'affiche :
" # N/A".
Y'a-t-il une astuce pour éviter cela, merci.

Frédéric
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 389
Oui,
En C3
avec Excel 2003:
=SI(ESTNA(RECHERCHEV($J$5;Feuil2!$A$10:$G$30;2;FAUX) );"Inconnu";RECHERCHEV($J$5;Feuil2!$A$10:$G$30;2;FAUX) )

Avec Excel 2007 une formule plus courte existe:
=SIERREUR(RECHERCHEV($J$5;Feuil2!$A$10:$G$30;2;FAUX) ;"Inconnu")

En J3
avec Excel 2003:
=SI(ESTNA(RECHERCHEV($J$5;Feuil2!$A$10:$G$30;3;FAUX) );"Inconnu";RECHERCHEV($J$5;Feuil2!$A$10:$G$30;2;FAUX) )

Avec Excel 2007 une formule plus courte existe:
=SIERREUR(RECHERCHEV($J$5;Feuil2!$A$10:$G$30;3;FAUX) ;"Inconnu")
ça peut être "inconnu" ou "" pour laisser la cellule vide.

Voici un tutoriel pour la fonction RECHERCHEV


Tout problème a une solution...il faut juste être persévérant.
Messages postés
3
Date d'inscription
mercredi 24 avril 2013
Statut
Membre
Dernière intervention
24 avril 2013

Merci à vous deux

Je mets résolu.

Bonne continuation

Frédéric