Failed to connect to mailserver at "smtp.orange.fr"

Résolu/Fermé
Arketran
Messages postés
2
Date d'inscription
vendredi 12 avril 2013
Statut
Membre
Dernière intervention
15 avril 2013
- Modifié par Arketran le 12/04/2013 à 13:20
legiux777
Messages postés
221
Date d'inscription
lundi 26 août 2013
Statut
Membre
Dernière intervention
21 janvier 2016
- 24 sept. 2013 à 18:16
Bonjour,

J'essaye de m'envoyer un mail en local avec le script suivant :

<?php 

/* Récupération des valeurs des champs du formulaire */ 
if (get_magic_quotes_gpc()) 
{ 
    $civilite = stripslashes($_POST['civilite']);  
    $nom = stripslashes($_POST['nom']);  
    $expediteur = stripslashes($_POST['email']);  
    $sujet = stripslashes($_POST['sujet']);  
    $message = stripslashes($_POST['message']);  
}  
else 
{   
    $civilite = $_POST['civilite']; 
    $nom = $_POST['nom'];  
    $expediteur = $_POST['email'];  
    $sujet = $_POST['sujet'];  
    $message = $_POST['message'];  
} 

/* Destinataire (votre adresse e-mail) */ 
$to = 'toto@mondomaine.com'; 
  
/* Construction du message */ 
$msg  = 'Bonjour,'."\r\n\r\n"; 
$msg .= 'Ce mail a été envoyé depuis monsite.com par '.$civilite.' '.$nom."\r\n\r\n"; 
$msg .= 'Voici le message qui vous est adressé :'."\r\n"; 
$msg .= '***************************'."\r\n"; 
$msg .= $message."\r\n"; 
$msg .= '***************************'."\r\n"; 
  
/* En-têtes de l'e-mail */ 
$headers = "From: sender@sender.com\n"; 
$headers .= "MIME-Version: 1.0\n"; 
$headers .= "Content-type: text/html; charset=iso-8859-1\n"; 

/* Envoi de l'e-mail */ 
mail($to, $sujet, $msg, "lullier.maxime@gmail.com"); 
?>


mais j'obtiens l'erreur :
Warning: mail() [function.mail]: Failed to connect to mailserver at "smtp.orange.fr" port 587, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\wamp\www\mail php\send_email.php on line 38

J'ai aussi essayé avec le port 25 mais rien à faire, une idée ?

A voir également:

1 réponse

legiux777
Messages postés
221
Date d'inscription
lundi 26 août 2013
Statut
Membre
Dernière intervention
21 janvier 2016
93
24 sept. 2013 à 18:16
en local faut que tu ailles activer la fonction mail car elle est de base désactivé si je me souviens bien.

il faut que tu ailles l'activer dans ton fichier : php.ini
0