PHP : Lien dans une variable

Résolu/Fermé
nik029 Messages postés 281 Date d'inscription mardi 1 juillet 2008 Statut Membre Dernière intervention 13 avril 2022 - Modifié par nik029 le 27/03/2013 à 11:41
nik029 Messages postés 281 Date d'inscription mardi 1 juillet 2008 Statut Membre Dernière intervention 13 avril 2022 - 27 mars 2013 à 11:53
Bonjour,

Mon problème est que mon lien ne fonctionne pas. Voici ce que j'ai fait :

<?php  
$id= ($_GET['id'] + 1); 
echo $id; 
?> 

die('Réponse enregistrée. 
   <br><br> 
    
   <a href="question.php?id="'.$id.'" class="btn btn-primary btn-large"> suivant </a>');


Tout fonctionne bien jusqu'à là mais quand je clique sur le lien, j'atterie sur une page avec un url comme cela :

http://nomdusite.com/question.php?id=


alors qu'il devrait y avoir par exemple :

http://nomdusite.com/question.php?id=10


Pouvez-vous m'aider ?

Merci d'avance.



Une fois un problème résolu, mettez un +1 sur la réponse qui vous à aidez et mettez Problème Résolu ! ;-)

2 réponses

ThEBiShOp Messages postés 8318 Date d'inscription jeudi 22 mars 2007 Statut Contributeur Dernière intervention 8 février 2021 1 598
27 mars 2013 à 11:45
Salut, ne mets pas les double quotes autour de ton id

die('Réponse enregistrée. 
   <br><br> 
    
   <a href="question.php?id='.$id.' class="btn btn-primary btn-large"> suivant </a>');
2
nik029 Messages postés 281 Date d'inscription mardi 1 juillet 2008 Statut Membre Dernière intervention 13 avril 2022 42
27 mars 2013 à 11:53
Effectivement, j'avais essayé toutes les solutions... sauf celle là.

Merci beaucoup !
0