Impossible d'installer l'extension initl de PHP

Résolu
Bonjour,

Pour le développement d'une application sous Symfony 3.2.2, j'ai besoin d'installer l'extension initl de PHP.
(je suis sous Ubuntu 16.04)

Lorsque j'exécute cette commande : sudo apt-get install php-intl

j'obtiens le message d'erreur suivant :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
php-intl is already the newest version (1:7.0+35ubuntu6).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 317 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/582 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
dpkg: erreur de traitement du paquet dbconfig-common (--configure) :
le paquet est dans un état vraiment incohérent; vous devriez
le réinstaller avant de tenter de le configurer.
Des erreurs ont été rencontrées pendant l'exécution :
dbconfig-common
E: Sub-process /usr/bin/dpkg returned an error code (1)


Il semble que dbconfig-common soit utilisé pour la configuration de ma base de données MySQL.

Je dois reinstaller le paquet en lui même ou phpMyAdmin en entier ?
Si vous avez les lignes de commandes qui vont bien avec c'est top :)

Merci

2 réponses

  1. Modérateur
    Bonjour,

    Le fait que le paquet soit dans un état incohérent laisse penser que ton installation actuelle est bancale. Commence par faire une mise à jour et installer
    aptitude
    :

    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install aptitude
    sudo aptitude update
    sudo aptitude safe-upgrade


    Assure-toi que tous les paquets sont à jour, non gelés, et pas bloqué. En outre si tu lances la commande
    aptitude
    , il ne faut pas que tu aies un "bandeau rouge" en bas d'écran, et si tu fais
    uUg
    il ne faut pas qu'il y ait de paquet gelés/maintenus et que tout soit à jour (
    q
    pour quitter).

    Bonne chance
    1
    1. Bonjour,

      Avant votre réponse j'avais trouvé une solution.
      J'avais déjà lu le coup de aptitude mais j'avais toujours un soucis avec dbconfig-common.

      Merci d'avoir pris le temps de m'aider en tout cas :)
      0
    2. Modérateur
      Pas de soucis, merci pour ton retour :-) Pour le problème avec dbconfig-common, s'il persiste et que tu veux le résoudre, n'hésite pas à ouvrir un nouveau sujet.

      Bonne continuation !
      0
  2. Après plusieurs essaies différents, j'ai trouvé une solution :

     sudo apt-get install --reinstall dbconfig-common
    sudo apt-get install php-intl
    sudo apt-get install phpmyadmin


    Il a fallu que je désinstalle phpmydmin, que je réinstalle dbconfig-common par la suite.
    0