AFFICHER LA VALEUR 1 OU ZERO DANS UNE COLONNE SI

Résolu/Fermé
FACITFR Messages postés 4 Date d'inscription lundi 4 mars 2013 Statut Membre Dernière intervention 5 mars 2013 - 4 mars 2013 à 10:49
FACITFR Messages postés 4 Date d'inscription lundi 4 mars 2013 Statut Membre Dernière intervention 5 mars 2013 - 5 mars 2013 à 11:40
Bonjour,

Dans un tableau d'activité mensuelle, je souhaite afficher la valeur 1 dans une colonne (la dernière) si dans une autre se trouve une date du mois en cours et 0 si la colonne date reste vide.
Le total des 1 represente l'activite mensuelle. Il peut y avoir plusieurs activite à la même date, donc plusieurs 1.
Pourriez-vous m'aider à solutionner mon problème ?

Merci d'avance.

7 réponses

michel_m Messages postés 16578 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 28 septembre 2022 3 279
Modifié par michel_m le 4/03/2013 à 11:37
Bonjour,

=(MOIS(A1)=MOIS(AUJOURDHUI()))*1

Et sans colonne intermédiaire donnant 1 ou 0,
nombre de 1 dans le mois actuel
=SOMMEPROD((MOIS(A1:A30)=MOIS(AUJOURDHUI()))*1)

Nota: Pourquoi le titre en majuscules: tu es en colère
lire cet extrait de la charte
https://www.commentcamarche.net/infos/25857-charte-de-commentcamarche-net-conseils-d-ecriture/
Michel
0
Raymond PENTIER Messages postés 56695 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 29 septembre 2022 17 180
4 mars 2013 à 12:40
reyny a été très clair "Cette formule fais ressortire les dates des 31 dernier jours".

Par conséquent il faut la modifier pour les mois qui ont moins de 31 jours ...
0
FACITFR Messages postés 4 Date d'inscription lundi 4 mars 2013 Statut Membre Dernière intervention 5 mars 2013
5 mars 2013 à 11:40
Merci à tous pour vos réponses instantanées qui me conviennent parfaitement.
C'était la première fois que je posais une question sur le site et je vous d'accepter encore une fois mes excuses pour mon manque de discernement.
0
=SI(A1>SOMME(AUJOURDHUI()-31);1;0)

A1 correspondant à la cellule de la ligne ou ce trouve la date

Cette formule fais ressortire les dates des 31 dernier jours.

Si vous souhaitez arrèter les dates au 1er du mois, il va falloir taper la date à la mano à la place de SOMME(AUJOURDHUI()-31
-1

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
FACITFR Messages postés 4 Date d'inscription lundi 4 mars 2013 Statut Membre Dernière intervention 5 mars 2013
4 mars 2013 à 11:48
Merci pour cette réponse rapide.
La formule de reyny me semble plus adapté à mon cas.
Elle fonctionne pour toutes les dates sauf pour le premier du mois.
Voici comment je l'ai retranscrite :
=SI(C5:C26>SOMME(AUJOURDHUI()-31);1;0)
Au premier février (01/02/2013) j'obtients 0 alors que cela fonctionne pour les autres jours. Ainsi que les 0 pour les cases vide.
J'ai le message suivant " La formule de cette cellule fait référence à une plge ayant des nombres supplémentaireqs adjacents" pour les cases de valeur 1 mais pas dans la première alors que le résultat devrait être 1.
Ai-je fait une erreur dans la transcription ?
-1
michel_m Messages postés 16578 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 28 septembre 2022 3 279
Modifié par michel_m le 4/03/2013 à 11:54
me semble....

As tu essayé ce que je t' ai donné

impression très nette d'avoir perdu mon temps
0
FACITFR Messages postés 4 Date d'inscription lundi 4 mars 2013 Statut Membre Dernière intervention 5 mars 2013
4 mars 2013 à 12:12
Mille excuses pour les majuscules. Je n'y avait pas prêté attention.

Merci pour votre aide.
-1
Une formule par date:
Si date en A:A et formule en B:B
en B2 =SI(A2>SOMME(AUJOURDHUI()-31);1;0)
en B3 =SI(A3>SOMME(AUJOURDHUI()-31);1;0)

faire défiler la formule

tu trouvera un 1 sur toutes les dates comprisent dans les 31 derniers jours.
-1