Afficher le mois en cours sur Excel 2010 [Fermé]

Signaler
Messages postés
7
Date d'inscription
lundi 18 février 2013
Statut
Membre
Dernière intervention
25 mars 2013
-
Messages postés
7
Date d'inscription
lundi 18 février 2013
Statut
Membre
Dernière intervention
25 mars 2013
-
Bonjour,

Je souhaiterais avoir une cellule dans mon tableau qui affiche le mois en cours au format mmmm-aa et non avec un chiffre.
Exemple : si je rentre la formule =MOIS(AUJOURDHUI) dans mon fichier, résultat = 2 alors que je voudrais qu'il affiche Févr. 2013. Si je choisis le format date cela ne fonctionne pas non plus. J'aurais ensuite des formules qui se rapporte à cette cellule (ex : ne prendre en compte dans une formule que les données du mois en cours)
Je ne sais pas si je suis suffisamment claire.
Pourriez-vous m'aider svp ?

D'avance merci !

3 réponses

Messages postés
1823
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
24 avril 2020
578
Bonjour,

Pour afficher le mois en clair, il suffit de laisser =AUJOURDHUI() dans la cellule et dans le format choisir un format personnalisé avec mmmm

Pour les formules, la cela dépend du type de formule désiré.

A+
Cordialement,
13
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57124 internautes nous ont dit merci ce mois-ci

Messages postés
1823
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
24 avril 2020
578
Oui Vaucluse à raison (bien sur !) j'ai pas bien lu
format mmmm.aaaa
ou mmm.aaaa si on veut le nom des mois court
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
Bonjour
clic droit /format de cellule /personnalisé et dans la fenêtre type:
mmmm.aaaa
La valeur numérique de la date est bien sur conservée.
crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
7
Date d'inscription
lundi 18 février 2013
Statut
Membre
Dernière intervention
25 mars 2013

Merci ! Si l'on garde la formule =MOIS(AUJOURDHUI) et que l'on choisit le bon format de date cela ne fonctionne pas (ça m'affiche janv-00) mais ça fonctionne bien avec =AUJOURDHUI().

Par contre ma formule de calcul matriciel ne fonctionne pas puisque si je la réfère à la cellule qui affiche le mois en cours (ici A2) elle ne prendra que les données par rapport à aujourd'hui.
=SOMME(('Suivi des jalons - livrables'!D15:D97="Livrable documentaire")*('Suivi des jalons - livrables'!$N$15:$N$97>=A2))

Dans l'idéal j'aimerais que la cellule A2 représente tout le mois en cours (ici la période 01/02/2013 - 28/02/2013). Ainsi je pourrais inscrire dans ma formule $N$15:$N$97=A2 et j'obtiendrais les données du mois de février complet uniquement.
Savez-vous si cela est possible ?
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
Re
sans changer grand chose, c'est toute la puissance de SOMMEPROD
=SOMME(('Suivi des jalons - livrables'!D15:D97="Livrable documentaire")*(MOIS('Suivi des jalons - livrables'!$N$15:$N$97)=MOIS(A2)))
Attention, si vos données couvrent plusiuers années vous allez toutes les retrouver, sauf si vous complétez
=SOMME(('Suivi des jalons - livrables'!D15:D97="Livrable documentaire")*(ANNEE('Suivi des jalons - livrables'!$N$15:$N$97)&MOIS('Suivi des jalons - livrables'!$N$15:$N$97)=ANNEE(A2)&MOIS(A2)))

*crdlmnt
Messages postés
1823
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
24 avril 2020
578
oui, autant utiliser SOMMEPROD au lieu de SOMME cela évite de valider par ctrl+shift+enter
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
Effectivement pilas, j'ai écris SOMME dans ma, formule, mais il s'agit bien de SOMMEPROD .
Je dois déjà dormir là!
bien cordialement
Messages postés
7
Date d'inscription
lundi 18 février 2013
Statut
Membre
Dernière intervention
25 mars 2013

Merci de votre aide !