Formule pour effacer des doublons sur une même ligne

[Fermé]
Signaler
-
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
-
Bonjour,

Êtant novice sur excelle je dois dédoublonner un énorme fichier. Voici mon problème les doublons se situent sur la même ligne (et non pas en colonne) et change tout le temps de valeur.
Je recherche donc une formule du type :
si E2 = à D2 alors effacer le contenu de E2 (que je pourrais transposer à tout mon tableau)


Merci d'avance pour vos solutions

1 réponse

Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 091
Bonjour
si vous voulez les enlever en manuel,(en nautomatqiue il faudrait une macro) le mieux est une MFC pour les détecter, car avec votre formule, il faut qu'ils se suivent pour que vous les trouviez.
Mise en forme conditionnelle / utiliser une formule
et pour un champ par exemple de E2 à Z2 ( à adapter), la formule est:
=NB.SI($E$2:$Z$2;E2)>1
et choisissez une couleur visible. Les cellules seront de cette couleur tant qu'il y aura plus d'une fois la ,même valeur dans la, ligne.
crdlmnt
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 091
J'ai fait une faite de frappe, ma grande spécialité, mais dans tous les cas si A1 est plusieurs fois dans le tableau il aurait du apparaître en rouge
=NB.SI($A1:$Z1;A1)>1
voyez ici (de A à N)
https://www.cjoint.com/?CBsr3ZJk4Yg
crdlmnt
Messages postés
4
Date d'inscription
lundi 18 février 2013
Statut
Membre
Dernière intervention
19 février 2013

D'accord, mais ca marche pour une ligne. Comme puis-je faire cette formule sur toutes les lignes du tableau sans recopier ligne par ligne?
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 091
Bonjour

Hé bé!!!Je pensais tout ça expliqué au message 4 un peu plus haut, mais je recommence:

Dans l'exemple que je vous ai soumis, voila comment j'ai procédé:

sélectionner le champ A1: N6
pour cela:
Aller dans la case à droite de la barre de formule, là ou s'affiche l'adresse de la sélection
Entrer au clavier: A1:N6 et taper enter
toustle champ est sélectionné.

MFC avec la formule qui correspond à la ligne 1 et en respectant bien la position des signes $:
(devant les adresses de colonne et pas les adresses de ligne et aucun pour l'adresse de cellule à la fin du code NB.SI
.SI
=NB.SI($A1:$N1;A1)>1
cette formule va s'adapter ligne par ligne sur toute la hauteur du champ


Plus qu'à adapter à vos données

crdlmnt
Messages postés
4
Date d'inscription
lundi 18 février 2013
Statut
Membre
Dernière intervention
19 février 2013

Super! Merci ca marche!! (désolé je suis un peu nul parfois...)
Par contre tant qu'on y est, aucun moyen pour que les doublons s'effacent automatiquement?
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 091
Peut être, si, mais là il faut du VBA et ça n'est pas dans mon domaine, désolé
Mais il y a des bons ici qui savent faire, ne désespérez pas!
si vous n'avez pas de réponse d'ici demain, relancez un sujet
Bonne chance
crdlmnt