[algorithme calcul pgcd]

Fermé
make1989
Messages postés
1
Date d'inscription
vendredi 23 février 2007
Statut
Membre
Dernière intervention
23 février 2007
- 23 févr. 2007 à 14:19
 ZAINPRODUCT - 18 oct. 2014 à 16:17
bonjour ,j'ai besoin d'áide svp: je n'arrive pas a trouve la solution de cet exo ,son enonce est :une autre methode proche de celle d'euclide est appele algorithme de nicomachos .elle est basee sur la soustraction a la place de la devision
pgcd (a,b) = pgcd (b,a-b) avec a >=b. construisez cet algorithme en utilisant les fonctions et les procedures. merci d'avance car la resolution de cet exo est un point de repaire pour moi.
A voir également:

12 réponses

Polux31
Messages postés
6917
Date d'inscription
mardi 25 septembre 2007
Statut
Membre
Dernière intervention
1 novembre 2016
1 193
16 nov. 2007 à 15:15
bonjour, je veux un moyen simple pour faire faire mon boulot à ma place ...

:o)

polux
40
informatique4_taba
Messages postés
17
Date d'inscription
vendredi 16 novembre 2007
Statut
Membre
Dernière intervention
20 novembre 2007
45
16 nov. 2007 à 16:13
voici un algorithme d' une fonction permettant de retourner le pgcd de 2 entiers données:

debut fonction PGCD_Dif(m,n:entier):entier
tant que (m<>n) faire

si m>n alors
m<----m-n
sinon
n<----n-m
finsi

fin tant que
PGCD_Diff<----m
fin pgcd

voici un tournage a la main:m= 21 etn= 15
21 <>15, 21>15 alors m=6 et n=15
6<>15, 6<15 alors n=9 et m=6
6<>9, 6<9 alors n=3 et m=6
6<>3, 6>3 alors m=3 et n=3
m=n=3 le condition d'arrêt de tant que ==> alors pgcd est le dernier valeur de m ou n =3
34
merci mean
0
merci............ j'ai pensé à une autre méthode très longue et j'a même pas eu de résultat ! vraiment merci du fond du coeur !
0
Je suis désolé mais je ne te suit pas
0
Ok
0
merci
0
entier a, b

écrire "Introduisez le 1er nombre: "
lire a
écrire "Introduisez le 2ème nombre: "
lire b
tant que NOT (a*b=0) faire
si a>b alors a <-- a-b
sinon b <-- b-a
fsi
ftant
si a=0 alors écrire "PGCD = ", b
sinon écrire "PGCD = ", a
fsi
23
TITRE ; Afficher le PGCD de 2 nbrs entier


variable:N, A,B. PGCD : (ENTIER)
DEBUT
ecrire " entrez le nombre de valeur "
lira A
ecrire "entrez le nombre de valeur "
lire B
PGCD-----0
pour i=0 a N-1
si (A>B) ALORS
A <--A-B
sinon
B <--B-A
finsi
fin pour
si A=0 alors
ecrire "PGCD est " : B
sinon


ecrire "PGCD est " : A
finsi
FIN




    
0
variables m,n en entier
debut
ecrire"m"
lire m
ecrire"n"
lire n
tantque m<>n faire
si m>n alors
m<------ m-n
sinon
n<------ n-m
finsi
fintanatque
ecrire"le pgcd =",m
fin
8
Franchement je n'y comprends rien du tout
0
voici un programme pr le pgcd de deux nbres
lire(a)
lire(b)
si(a<b) alors
{d<---a
a<---b
b<---d
}
tanque(a mod b <>0) faire
{d<---a mod b
a<---b
b<---d
}
afficher( " le pgcd est",b)
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
chafikislam
10 nov. 2010 à 11:27
bonjour tout le monde

on peut utiliser la récursivité :

if(p>q)
return pgcd(p-q,q);
else if(q>p)
return pgcd(p,q-p);
else
return p;
8
bjr
je veux avoir un algo qui permet de calculer et afficher le pgcd de deux nombres.
et le plus vite possible merci d'avance.
6
en iteratif:
a et b sont donnés
pgcdIteratif(int a,int b):Int
int d1,d2,r;
if(a>=b){
d2=a;
d1=b;
}
else{
d2=b;
d1=a;
}
r=d2%d1;
if(r==0)
return d1;
else{
while(r!=0){
d2=d1;
d1=r;
if(d2%d1==0)
return r;
else
r=d2%d1;
}
return r;
}



en recursif:
pgcdrecursif(int a,int b):Int
int d1,d2,r;
if(a>=b){
d2=a;
d1=b;
}
else{
d2=b;
d1=a;
}
if(d1==0)
return 0;
else if(d2%d1==0){
return d1;

}
else{

return rec(d2,d1,d2%d1);
}

}

rec(int d2,int d1,int r):Int
if(d2%d1==0)
return d1;
else
return rec(d1,r,d1%r);
6
sa c quel language
0
voici un algorithme d' une fonction permettant de retourner le pgcd de 2 entiers données:

debut fonction PGCD_Dif(m,n:entier):entier
tant que (m<>n) faire

si m>n alors
m<----m-n
sinon
n<----n-m
finsi

fin tant que
PGCD_Diff<----m
fin pgcd
4
var a,b:entier
debut
ecrire 'introduisez a'
lire a
ecrire "introquisez b"
lire b
ecrire 'a'\'b'=a\b
ecrire si' r=0" "PGDC"=b
sinon a<----b
b<-----r
fin
4
tu fai 5*7-54 et c bn normalement a++
3
SLT
JE VOUDRAI BEIN QU'ON M'AIDE
voici l'exo
ecrire l'algorithme qui calcul le minimum de deux nombres A et B
0
Bonjour, j'ai un petie probléme je veut une methode simple d'un algorithme qui calcule le pgcd
2
P.G.C.D(a,b)




Si a est div par b ou b est div par a Si a n'est pas div par b ou b n'est pas div par a


PGCD(a,b)=b ou PGCD(a,b)=a PGCD(a,b)=1
0
et en forma casio graphe 35 + sa donne quoi???
1