Additionner les résultats de plusieurs lignes différentes [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
lundi 28 janvier 2013
Statut
Membre
Dernière intervention
28 janvier 2013
-
Messages postés
4
Date d'inscription
lundi 28 janvier 2013
Statut
Membre
Dernière intervention
28 janvier 2013
-
Bonjour,

Je travaille avec Excel 2010 et je voudrais connaître la formule pour additionner les résultats de vente détaillés de différents vendeurs.

Mon tableau ressemble à ceci :

15-janv Phil 1
15-janv anja 1
16-janv Phil 3
17-janv Sandra 1
17-janv Valérie 2
17-janv Edith 1
18-janv Valérie 3
18-janv Anja 2
19-janv Phil 1
19-janv Nadine 1

Je voudrais donc avoir une cellule ou serait calculée automatiquement le total pour Phil (égal à 5), une autre pour Anja (égal à 3), etc...

D'avance merci pour votre aide.

@+

Phil

3 réponses

Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 393
Bonjour
Faite un tableau avec (exemple à adapter):
en A lles date
en B les noms
En C les valeurs
et puis une second avec:
en D la liste exhaustive des noms
et en E la formule à tirer sur la hauteur de cette liste, si on commence en E1:

=SOMME.SI(B;B;D1;C:C)

crdlmnt


Messages postés
4
Date d'inscription
lundi 28 janvier 2013
Statut
Membre
Dernière intervention
28 janvier 2013

Grand merci, c'est ce que je cherchais.
Messages postés
17158
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
5 août 2020
4 158
Salut le fil,

De A2 à A20 par exemple les dates, de B2 à B20 les Noms et de C2 ;à C20 les nombres à additionner

=SOMMEPROD((B2:B20="Phil")*(C2:C20))

Ou tu crées une liste de validation en E1 pour sélectionner tes noms et la formule devient

=SOMMEPROD((B2:B20=E1)*(C2:C20))

https://www.cjoint.com/c/CACsSCWHjnP
Messages postés
4
Date d'inscription
lundi 28 janvier 2013
Statut
Membre
Dernière intervention
28 janvier 2013

Merci, c'est une autre variante, mais le résultat est aussi ce que je cherchais.
Messages postés
9
Date d'inscription
dimanche 27 janvier 2013
Statut
Membre
Dernière intervention
31 janvier 2013

bonjour
je t'ai fait un exemple et tu peux ouvrir une feuille par mois avec le meme principe dans ton classeur et en ouvrir une comme bilan. J'ai fait le tableau si cela t'interresse donne moi ton e-mail je te l'enverrai. Les calculs se font automatiquement

1 feuille pour janvier
A B C D E F G
1 Date Nom
2 Phil Anja Sandra Valérie Edith Nadine
3 15-janv 1 1
4 16-janv 3
5 17-janv 1 2 1
6 18-janv 1 2 3
7 19-janv 1
8 20-janv
9 21-janv
10 22-janv
11 23-janv
12 24-janv
13 25-janv
14 26-janv
15 27-janv
16 28-janv
17 29-janv
18 30-janv
19 31-janv
5 3 1 5 1 1



pour additionner tu selectionne la cellule où tu souhaites avoir le résulta et tu tappe =somme(
ensuite tu selectionne la cellule du début avec le bouton gauche de ta souris et sans lacher tu selectionne l'ensemble des cellules que tu veux additionner et ensuite tu tappe la parenthèse ) et tu tappe sur la touche Entrée de ton clavier
Exemple pour Phil ta formule sera:
=SOMME(B3:B19)
ensuite pour les autre il te sufit de selectionner ta cellule où tu as ta formule, tu prend le point qui se trouve en bas à droite et quand ton curseur se transforme en une croix tu tires dessus jusqu'à la cellule ou tu veux que se calcul pour nadine et tes formules se mettont automatiquement. Si non tu refait la manipe pour chaque cellule
amicalement
Messages postés
4
Date d'inscription
lundi 28 janvier 2013
Statut
Membre
Dernière intervention
28 janvier 2013

Merci, mais comme les entrées se font au fure et à mesure et qu'il n'y a pas nécessairement de données tous les jours, les formules avec Somme.si ou Sommeprod me conviennent mieux.