Formule =Si, petite question [Résolu/Fermé]

Signaler
-
Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
-
Bonjour,

Je voudrai savoir comment écrire la formule pour ce cas de figure:

La cellule A1, cellule ou la formule doit s'inscrire, j'aimerai que le mot "Forfait" apparaisse si dans la cellule B1 j'inscris n'importe quel chiffre.

J'ai essayé de cette façon:
=SI(B1="nombre";"Forfait";"")

Mais ça n'a pas fonctionné.
Help? ^^

El Kemao

6 réponses

Messages postés
1147
Date d'inscription
lundi 10 mai 2010
Statut
Membre
Dernière intervention
26 décembre 2020
102
Bonjour,

Essaye ca,

=SI(B1>0;"Forfait";"")

Cordialement,
Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 505
Salut,

Je n'ai pas tout compris mais tu peux tester
=SI(B1<>"";"Forfait";"")

=SI(ESTNUM(B1);"Numérique";"pas numérique")
ou
=SI(ESTNUM(B1);"Numérique";"Forfait")
bien sur à adapter
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
1
Date d'inscription
lundi 14 janvier 2013
Statut
Membre
Dernière intervention
14 janvier 2013

J'ai reçu la réponse de la par de Noreply:

Formule:

=SI(B1>0;"Forfait";"")

ça marche!
Merci beaucoup, sujet clos.

El Kemao
Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 505
Re,

A la seule différence que cette formule

=SI(B1>0;"Forfait";"")

ne teste pas si la valeur en B1 est un chiffre mais simplement si B1 est renseigné
Messages postés
15271
Date d'inscription
jeudi 14 juillet 2011
Statut
Contributeur
Dernière intervention
15 décembre 2020
6 246
Le fait d'inclure >0 (supérieur à 0) indique qu'il s'agit bien de chiffre... non ?
Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 505
Re,

Et non, teste la formule et saisi n'importe quelle valeur numérique ou texte
"Forfait" s'affichera

cordialement
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
15271
Date d'inscription
jeudi 14 juillet 2011
Statut
Contributeur
Dernière intervention
15 décembre 2020
6 246
Exact... j'aurais dû vérifier ;-)
Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 505
Re,

Un forum est une mine d'or et si l'on est curieux, on découvre tous les jours de nouvelles fonctions.
Dans le cas présent on peut tester si la cellule est numérique ou texte. Ce qui est plus compliqué est de tester si la valeur alphanumérique est une date par exemple
Cordialement