Supprimer la fenetre.......... [Résolu/Fermé]

Signaler
Messages postés
99
Date d'inscription
mercredi 19 décembre 2012
Statut
Membre
Dernière intervention
13 octobre 2019
-
Messages postés
99
Date d'inscription
mercredi 19 décembre 2012
Statut
Membre
Dernière intervention
13 octobre 2019
-
Bonjour,

Comment supprimer la fenêtre qui apparait à l'ouverture du fichier:

"""""le fichier contient des macros"""""""
""désactiver les macros""
""activer les macros"" ?

https://www.cjoint.com/?BLwoxMfoVWz

merci

3 réponses

Messages postés
8536
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
8 mai 2021
1 660
Il suffit de supprimer les macros :

https://www.cjoint.com/?0Lwo0blXUBi
Messages postés
99
Date d'inscription
mercredi 19 décembre 2012
Statut
Membre
Dernière intervention
13 octobre 2019

oui, OK ! sauf que c'est pas moi qui ai fait le document ? Déjà, je sais pas ou sont les macros ni comment les retrouver ? alors pour les supprimer ? et puis, a quoi elles servent, ces macros, sont elles bien utiles ?

j'apporte modif à mon message:
j'avais pas vu que les macros étaient déjà supprimées ? (j'ai pas ré-ouvert le doc)
Mais ma question reste: c'était quoi ces macros, et a quoi servaient elles ?
merci Patrice
Messages postés
8536
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
8 mai 2021
1 660
C'est probablement des résidus d'anciennes macro, ça sert à rien !
Messages postés
8536
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
8 mai 2021
1 660
Pour supprimer les macros, ouvrir le VBE : Alt+F11
Si besoin, afficher la fenêtre de l'explorateur de projet : Affichage / Explorateur de projet
Dans cette fenêtre, double cliquer du Feuil1 : le texte de la macro apparait dans la fenêtre principale.
Sélectionner et effacer tout le texte (Option Explicit .... End Sub)
Répéter l'opération pour Feuil 3 puis Thisworkbook
Fermer le VBE et enregistrer le fichier

Cordialement
Patrice
Messages postés
99
Date d'inscription
mercredi 19 décembre 2012
Statut
Membre
Dernière intervention
13 octobre 2019

merci Fabrice, c'est réglé.
Problème résolu.
bonnes fêtes de fin d'année.