Sommeprod mais pas sur?

Résolu/Fermé
romanza Messages postés 250 Date d'inscription samedi 27 janvier 2007 Statut Membre Dernière intervention 4 octobre 2021 - Modifié par irongege le 16/12/2012 à 12:49
romanza Messages postés 250 Date d'inscription samedi 27 janvier 2007 Statut Membre Dernière intervention 4 octobre 2021 - 16 déc. 2012 à 13:18
Bonjour,


J'ai essayé de vous coller une partie de mon tableau Excel.

Voilà mon problème.

Je souhaite connaître par ville le nombre cumulés de visiteurs à une date donnée quand le motif BM est SAV

01/10/2012 02/10/2012 03/10/2012 04/10/2012
Ville1
Motif BM SAV SAV
A
B
Nbre visiteurs 28 31 34 37
D
E 1000 2000 3000 4000
F
G
H
Ville2
Motif BM Mutu SAV
A
B
Nbre visiteurs 56 65 74 83
D
E
F
G 543 610 677 744



Merci à vous




9 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
15 déc. 2012 à 19:29
Bonsoir
plutôt que ce message qui est quasiment inutilisable, placez plutôt votre tableau sur
https://www.cjoint.com/
et revenez ici avec le lien donné par le site.
Crdlmnt
0
romanza Messages postés 250 Date d'inscription samedi 27 janvier 2007 Statut Membre Dernière intervention 4 octobre 2021 2
16 déc. 2012 à 09:42
Bonjour,

Voici le fichier


https://www.cjoint.com/?3LqjOD0C4aF

Merci à vous
0
Patrice33740 Messages postés 8549 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 7 mai 2022 1 756
Modifié par Patrice33740 le 16/12/2012 à 09:59
Bonjour,

Pour la ville 1 :
=SOMME.SI(D4:N4;"SAV";D7:N7)

Cordialement
Patrice
0
romanza Messages postés 250 Date d'inscription samedi 27 janvier 2007 Statut Membre Dernière intervention 4 octobre 2021 2
16 déc. 2012 à 11:22
Bonjour,

merci à vous mais je souhaiterais pouvoir calculer ce chiffre en deça d'une date choisie.

J'ai essayé cette formule qui ne fonctionne que si la date est sous forme de nombre (ici 41187). Si je saisi par exemple une date en A1 (la date choisie) et que dans la formule à la place de 41187 je mets "A1", ça ne marche pas



=SOMME.SI.ENS(D7:N7;D4:N4;D4;D2:N2;"<41187")
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Patrice33740 Messages postés 8549 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 7 mai 2022 1 756
16 déc. 2012 à 11:48
Re,

Je n'ai pas Excel 2007 ou 2010 sous la main (et donc pas SOMME.SI.ENS), voici donc une proposition avec une formule matricielle :
=SOMME((D2:N2<DATEVAL("06/10/2012"))*(D4:N4=$D$4)*D7:N7)
à valider par Maj+Ctrl+Entrée
0
Patrice33740 Messages postés 8549 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 7 mai 2022 1 756
16 déc. 2012 à 11:49
Ou :
=SOMME((D2:N2<$A$1)*(D4:N4=$D$4)*D7:N7)
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
16 déc. 2012 à 12:39
Bonjour

essayez avec:
=SOMME.SI.ENS(D7:N7;D4:N4;D4;D2:N2;"<"&A1)

cependant; la formule telle que vous l'avez écrite fonctionne, je l'ai testée. (Donne 62)
Où la placer vous dans votre tableau?
crdlmnt

0
romanza Messages postés 250 Date d'inscription samedi 27 janvier 2007 Statut Membre Dernière intervention 4 octobre 2021 2
16 déc. 2012 à 12:48
Merci pour cet éclaircissement,

Cela fonctionne pour la première mais il faudrait que pour chaque ville j'aille dans la formule pour modifier la date.

Pour la seconde formule, ça ne va pas. J'ai mis une date en A1 et j'ai 0

Merci à vous
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
16 déc. 2012 à 12:57
Cela fonctionne très bien avec une cellule de référence pour la date.
Voyez ici il suffit de mettre en A en ligne avec le résultat en B la date que vous souhaitez

https://www.cjoint.com/?BLqm3xmCabw

au dela de ça il faudrait peut être nous en dire plus sur ce que vous voulez faire?
à+
0
romanza Messages postés 250 Date d'inscription samedi 27 janvier 2007 Statut Membre Dernière intervention 4 octobre 2021 2
16 déc. 2012 à 13:18
merci à Patrice et Vaucluse,

Vous avez résolu mon problème et cela m'avance bien pour mon boulot.

Très bon dimanche à vous.

Pascal
0