[GRUB] error: no such device

[Résolu/Fermé]
Signaler
Messages postés
42
Date d'inscription
lundi 19 décembre 2011
Statut
Membre
Dernière intervention
6 août 2018
-
Messages postés
42
Date d'inscription
lundi 19 décembre 2011
Statut
Membre
Dernière intervention
6 août 2018
-
Bonjour à tous.
Je viens vous faire part d'un problème qui m'est arrivé récemment sur mon ordinateur fixe.
J'ai installé debian il y a peu, mais voulant essayer autre chose, j'ai supprimé à la va-vite la partition sur laquelle il se situé.

Le problème est que au démarrage, avant le grub, il me met ceci :
"Welcome to GRUB!
error: no such device : "une série de chiffre et de numéros"
Entering rescue mode...
grub rescue> "
Et si je fais entrer ou que j'appuie sur n'importe quel touche il me remet "grub rescue>" en boucle.

La mise en place de mes disque durs :
1) Windows 7 + GRUB
2) La partition Linux qui a été supprimé
3)4) Espace de stockage

Après l'installation de Debian, le GRUB m?affichai deux Windows 7.

J'aurais donc aimé savoir comment le problème pouvait être corriger sachant que je ne peu donc pas lancer Windows 7... Sauf si je boot directement sur le DD en question (ce qui revient à marteler la "echap" à chaque démarrage).

Merci

5 réponses


Bonjour,

Il faut modifier la séquence de boot je pense.
J'avais eu un problème similaire et j'avais téléchargé Ubuntu (lancement en live). Ensuite sur ubuntu il y a le gestionnaire de disque qui permet de changer la séquence de boot.

Bon après, il y a peut être des solutions plus simples.
Messages postés
1231
Date d'inscription
mardi 7 juin 2011
Statut
Membre
Dernière intervention
24 mai 2015
342
Bonjour,

Si tu as l'intention d'essayer une autre distribution Linux (ou BSD), il suffira de réinstaller Grub pendant l'installation, et ton problème sera résolu.

Si tu souhaites récupérer la place pour windows, il faudra restaurer le MBR de windows (avec les outils proposés par ce système, je ne les connais pas mais je sais qu'ils existent).

Messages postés
42
Date d'inscription
lundi 19 décembre 2011
Statut
Membre
Dernière intervention
6 août 2018

Ad2351 --> Faudrait que j'essaie ;)

laoshu --> J'ai essayé de réinstaller le GRUB en réinstallant Debian mais l'installation bloqué à... l'analyse des disque... Pourtant, j'ai vérifié et il n'y aucun problème de DD... C'est le GRUB qui fait tout foirer.
Et sinon oui, faudrait que je réinstalle le MBR de Windows mais je n'ai aucun CD W7 donc ça va être dur ^^
Messages postés
1231
Date d'inscription
mardi 7 juin 2011
Statut
Membre
Dernière intervention
24 mai 2015
342
Quelle est l'erreur que tu rencontres lors de l'analyse des disques ?

Le GRUB de ton disque dur interne ne devrait pas être consulté lorsque tu démarres sur un CD/DVD ou une clef USB. Et je ne vois pas comment il pourrait perturber l'installation.

Si tu as un support pour une session «live», tu peux booter dessus et réinstaller GRUB sur ton ordi, ce qui mettra sa configuration à jour. Tu pourras alors démarrer tranquillement jusqu'à la prochaine modification des partitions... mais je doute que cela résolve ton problème d'installation.

bon courage,
Messages postés
42
Date d'inscription
lundi 19 décembre 2011
Statut
Membre
Dernière intervention
6 août 2018

Je n'ai rencontré aucune erreur lors de l'analyse des disques.
Si je boot directement sur le DD de Windows ou Ubuntu (que je viens de réinstaller) j'accède au grub de Ubuntu qui lui fonctionne sans soucis, si je boot sur un CD/DVD je n'ai aucun problème.

Grosso modo, le GRUB de Debian agi comme une sorte de virus dont on ne peut pas se débarrasser et qui s'affiche à chaque fois si on allume le PC normalement.
Messages postés
1231
Date d'inscription
mardi 7 juin 2011
Statut
Membre
Dernière intervention
24 mai 2015
342
Si tu as installé Ubuntu, tu as réinstallé GRUB. Ton problème devrait donc avoir disparu.

La seule possibilité que le problème persiste serrait que tu aies installé GRUB (avec Ubuntu) ailleurs que sur /dev/sda
Si tel est le cas, boot sur Ubuntu, ouvre un terminal et tapes:
sudo grub-install
Et choisi /dev/sda comme destination de l'installation.

Ça va peut-être te faire peur, mais Ubuntu est issu de Debian, et GRUB est un logiciel indépendant et il se trouve que Debian et Ubuntu utilisent le même. Le problème que tu rencontres vient de la configuration de ton ancien GRUB, qui cherche en vain une partition qui n'existe plus. En remplaçant ton ancienne config par la nouvelle, tu écraseras le problème et ton ordi bootera normalement.
Messages postés
42
Date d'inscription
lundi 19 décembre 2011
Statut
Membre
Dernière intervention
6 août 2018

Je viens de faire exactement que tu m'as dis.
Ubuntu m'a confirmé que tout était ok, au reboot j'ai toujours ce foutu grub debian de mes deux qui fait tout buggé.
Messages postés
42
Date d'inscription
lundi 19 décembre 2011
Statut
Membre
Dernière intervention
6 août 2018

Sujet résolu, je me suis aidé de ce tuto : http://www.siteduzero.com/tutoriel-3-186926-desinstaller-gnu-linux-et-ne-garder-que-windows.html