Validation w3c [Résolu/Fermé]

Signaler
-
 jon -
Bonjour a tous,

Je n'arrive pas a réparer c'est erreur:


Error Line 43, Column 86: document type does not allow element "table" here

... <table border="0" align="center" cellpadding="0" cellspacing="0" width="100%">


The element named above was found in a context where it is not allowed. This could mean that you have incorrectly nested elements -- such as a "style" element in the "body" section instead of inside "head" -- or two elements that overlap (which is not allowed).

One common cause for this error is the use of XHTML syntax in HTML documents. Due to HTML's rules of implicitly closed elements, this error can create cascading effects. For instance, using XHTML's "self-closing" tags for "meta" and "link" in the "head" section of a HTML document may cause the parser to infer the end of the "head" section and the beginning of the "body" section (where "link" and "meta" are not allowed; hence the reported error).
Error Line 46, Column 31: there is no attribute "alt"

<td width="50%" alt="" class="green" ><em>. . . Texte.</em></t...


You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead).

This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information.

How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute. If you received this error when using the <embed> element to incorporate flash media in a Web page, see the FAQ item on valid flash.


Merci pour votre aide.

1 réponse

Messages postés
1189
Date d'inscription
dimanche 3 janvier 2010
Statut
Membre
Dernière intervention
4 août 2018
245
As-tu pris la peine de traduire ce qui est écrit ? ( même avec google traduction ca aide déjà )

La première erreur, l'élément table n'est pas à ca place.
Etant donné que c'est un élément de type block est-ce que tu ne l'aurais pas insérer dans un autre block ou pire dans un élément de type inline ?

L'erreur avec le "alt" est claire, il ne faut pas de alt à un élément td.
Merci.
Et bien il est dans la table <table align="center" border="0" cellpadding="0" width="940">
mais j'ai mis d'autre sous table qui marche nickel.
La table concerner:
<table border="0" align="center" cellpadding="0" cellspacing="0" width="100%">
<tr>
<td width="50%"><img src="../images/test.jpg" width="470" height="150" alt="" /></td>
<td width="50%" class="header" ><em>. . . Texte.</em></td>
</tr>
</table>
Messages postés
1189
Date d'inscription
dimanche 3 janvier 2010
Statut
Membre
Dernière intervention
4 août 2018
245
Si tu traduisais le texte tu aurais ceci :
L'élément nommé ci-dessus a été trouvé dans un contexte où il n'est pas permis. Cela pourrait signifier que vous avez incorrectement imbriqué éléments - comme un "style" élément dans le «corps» de l'article plutôt qu'à l'intérieur "la tête" - ou deux éléments qui se chevauchent (qui n'est pas autorisé).
On ne peut pas faire plus clair, quelque part tu as mal imbriqué ton tableau, donc vérifie ton code et l'imbrication.