Gedit : pb sauvegarde d'un fichier partagé [Résolu/Fermé]

Signaler
Messages postés
666
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
-
Messages postés
666
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
-
Bonjour,

J'ai installé debian sur la machine virtuelle VirtualBox et ai partagé un dossier de mon système hôte (windows 7).

Quand j'ouvre des fichiers avec gedit, je n'arrive pas à les enregistrer. Il m'indique l'erreur suivante : "Erreur lors du renommage du fichier temporaire : Fichier texte occupé". Cette erreur concerne les fichiers préexistants. Je peux cependant créer mes propres fichiers, toujours dans le dossier monté, sans avoir la possibilité de les modifier à nouveau.

Ce problème ne concerne a priori que gedit. Les fichiers sont modifiables avec vim par exemple. Toutes les commandes pour copier (cp) et déplacer (rm) marchent très bien. Il ne s'agit donc pas de soucis de permissions. D'ailleurs, le dossier est bien monté sous mon nom d'utilisateur et j'en possède tous les droits.

Voici la ligne de commande que j'utilise pour monter mon dossier (que j'ajoute au fichier "/etc/rc.local") :
mount -t vboxsf -o uid=1000,gid=1000,umask=0 maVmSource ~/monDossierLinux/

Il ne s'agit pas non plus du fameux problème de gedit à ne pas enregistrer par défaut sur un dossier ftp. J'ai bien vérifié dans gconf-editor > apps > gedit2 > ... > save la présence de ftp.

J'ai visité beaucoup de sites sans réussir à trouver une solution.

J'ai cependant une remarque. Je ne sais pas ce qui s'est passé, mais, il y a un dossier pour lequel je n'ai pas les permissions en écriture "w" mais où j'arrive à enregistrer mes fichiers. Il est le seul qui sort du lot. Pour les autres dossiers, j'ai toutes les permissions, mais l'enregistrement ne se fait pas.
Il y a également une commande qui ne marche pas; la fameuse chmod. Son utilisation ne soulève pas d'erreur, mais elle n'a pas d'effet sur mes dossiers partagés, même en étant utilisée en root.

Merci pour votre aide!




C. Taha

5 réponses

Messages postés
666
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
75
Bonjour,

J'ai trouvé une solution pour sauvegarder mes fichiers. Mais elle n'est pas la meilleure, j'espère trouver mieux.

Tout d'abord, il faut permettre les backup de sauvegarde :
Édition > Préférences > Éditeur > Créer une copie de sauvegarde des fichiers avant l'enregistrement

Maintenant la sauvegarde se fait en deux étapes; au premier clic, je reçois le message d'erreur que j'ai cité au sujet Erreur lors du renommage du fichier temporaire : Fichier texte occupé. On annule le message et le second clic sur le bouton sauvegarder permet maintenant de la faire.

Comme vous voyez, cela permet de sauvegarder, mais l'utilisation de gedit reste tout de même gênante vu qu'il faut à chaque fois faire trois cliques au lieu de un. En absence de choix, j'utilise cette méthode jusqu'à l'apparition de l'élu!

Merci pour les anciennes interventions.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

j'ai le même problème avec une machine virtuelle et un dossier partagé depuis la commande suivante :
sudo mount -t vboxsf partage Public
Que faire ?
de plus ça me créer plein de fichiers .goutputstream-XXXXX dans le dossier où j'essaye d'enregistrer le fichier modifié avec geany OU gedit (pas de problèmes avec Eclipse ou QtCreator ... wtf ?)
Ce problème n'est pas rencontré si le fichier se trouve dans un dossier "normal" ( pas mount )
Messages postés
666
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
75
Effectivement, ce problème n'est présent que pour les dossiers montés (à partir d'un système NTFS a priori) et pas pour les fichiers locaux.

Ce que j'ai fait pour contourner cela, c'est que j'ai activé l'option "Créer une copie de sauvegarde des fichiers avant l'enregistrement".
Pour enregistrer, je fais ctrl+s, alt+n, ctrl+s au lieu de ctrl+s habituelle.

Je n'ai pas encore trouvé de solution définitive.
Messages postés
1364
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 juin 2013
231
Si ça se trouve, GEDIT créé un fichier swap par fichier ouvert et ne l'efface pas quand tu le referme, et le coup d'après, le fichier swap lui interdit de modifier le fichier.
Messages postés
666
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
75
Je ne connais pas la procédure de sauvegarde des fichiers par gedit. Il doit sûrement passer par un fichier temporaire qu'il supprime après. Mais je ne sais pas comment contourner ce problème.
Je me demande même s'il y en a chez qui ça fonctionne.
Messages postés
1364
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 juin 2013
231
T'as essayé de lancer un lsof depuis le client Virtualbox pour voir quel process accédait au fichier ?
Messages postés
666
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
75
Mon système client est windows 7.
Je n'ai aucune application qui utilise ce ficher. Le seul programme qui tourne, outre les processus du système, c'est mon vmbox.
Je ne pense pas que c'est une histoire de fichier ouvert par un autre programme. J'ai bien vérifié cela. La preuve c'est que je peux modifier le fichier par vim et je peux le supprimer ou le déplacer.
Je pense qu'il faut se concentrer sur gedit et sa manière de sauvegarder qui probablement crée des fichiers intermédiaires.

Merci quand même!
Messages postés
1364
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 juin 2013
231
Alors si c'est pas un process, et que ça n'affecte que les fichiers qui ont déjà étés ouvert avec GEDIT, c'est un fichier swap, je n'ai pas d'autre explication.
Messages postés
1
Date d'inscription
samedi 25 octobre 2014
Statut
Membre
Dernière intervention
25 octobre 2014

ça semble être un vieux problème non résolu, documenté ici
https://bugzilla.gnome.org/show_bug.cgi?id=656225
Messages postés
666
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
75
Ça semble être la réponse à la question.
Je vais marquer les sujet comme résolu sous réserve de vérification.
Merci pour votre réponse.