VBA : Somme si valeur de cellule différentes [Résolu/Fermé]

Signaler
Messages postés
471
Date d'inscription
mardi 1 juin 2004
Statut
Membre
Dernière intervention
21 février 2018
-
Messages postés
9633
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
19 novembre 2020
-
Bonjour,
je bute sur une compilation de formule :


je veux en C2 la somme des cellules de B1+B2 si A1<>A2

j'ai donc essayé :
=SOMMEPROD(SI(A1;"<>";A2)*(B1+B2)) mais c'est pas ca ^^

Si vous avez une solution à m'apporter.
Merci d'avance




6 réponses

Messages postés
9633
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
19 novembre 2020
1 973
bonjour

pas besoin, si j'ai compris,de compliquer les choses
C2=SI(A1<>A2;B1+B2;"")
donne la somme de B1 et de B2 si A1<>A2 sinon rien

bonne suite
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
9633
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
19 novembre 2020
1 973
ceci ?

C2=SI(A1<>A2;LIGNE();"")

bonne suite
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
471
Date d'inscription
mardi 1 juin 2004
Statut
Membre
Dernière intervention
21 février 2018
39
ouep merci. plutôt simple. par contre j'hésite à réouvrir un sujet... ::

je veux créer autand de optionbouton que j'ai de ligne dans une colonne. avec bien sur comme caption le contenu de la cellule.
Alors j'ai reussi ca :
Private Sub CommandButton1_Click()
Dim i As String

    With Worksheets("Valeurs")
    
    wksV_SiteR = 3
       
       While .Cells(wksV_SiteR, 2) <> ""

            t = wksV_SiteR * 100
            
            'Création de boutons d'action sur la feuille
            With ActiveSheet
                LargeurBouton = Columns(9).Width
                GaucheBouton = Columns(9).Left + 5
                HauteurBouton = 20
                SommetBouton = wksV_SiteR * 20
            End With
    
            Set oOLE = ActiveWorkbook.ActiveSheet.OLEObjects.Add(ClassType:="Forms.OptionButton.1", Link:=False, DisplayAsIcon:=False, Left:=GaucheBouton, Top:=SommetBouton, Width:=LargeurBouton, Height:=HauteurBouton)
                
            wksV_SiteR = wksV_SiteR + 1
        Wend
        
    End With

End Sub

Mais j'arrive pas à modifier la caption ...

help ??
Messages postés
471
Date d'inscription
mardi 1 juin 2004
Statut
Membre
Dernière intervention
21 février 2018
39
j'ai eu c'est bon ^^

Solution : =SOMME(SI(A1<>A2;B1:B2))
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 355
Salut,

Pourquoi SOMMEPROD, regarde plus simplement avec une conditionnelle

=SI(A1<>A2;SOMME(B1:B2);"")

mais si A1 est égale à A2 que fait on ?

L'utilisation de la fonction SOMME évite un message d'erreur si une cellule cible contient du texte
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
471
Date d'inscription
mardi 1 juin 2004
Statut
Membre
Dernière intervention
21 février 2018
39
re, merci mais comme j'avais marqué j'ai trouver.

par contre : il y as un moyen de saisir dans une cellule :

si a1<>a2 = le numéro de la ligne actuel ?
Messages postés
9633
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
19 novembre 2020
1 973
bonjour,

il aurait effectivement été préférable d'ouvrir une autre discussion
un exemple de création de boutons radios avec modification des propriétés nom et caption
https://www.cjoint.com/?BFqlUwQv3F1

bonne suite