Excel: combinaison NB.SI et sous.total???????

Résolu/Fermé
Romain 75009 - 30 avril 2012 à 17:31
 Romain 75009 - 2 mai 2012 à 15:38
Bonjour,

J'aimerai combiné sur Excel la fonction NB.SI et sous.total... Pour que la cellule me calcule le nombre de cellule contenant un mot mais que ce nombre bouge en fonction des filtres.
Merci

A voir également:

3 réponses

Mike-31 Messages postés 18320 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 20 juin 2024 5 086
30 avril 2012 à 21:09
Re,

le plus simple serait de séparer la chaine après l'espace entre l'année et le produit
mettre la plage à traiter en surbrillance puis Données/Convertir/cocher délimiter/cocher Espace/Terminer
la formule serait
=SOMMEPROD((A1:A20=("1-oct-10")*1)*(B1:B20="Ananas"))
pour les dates et les produits il serait judicieux de les saisir dans des cellules et dans la formule faire référence à ces cellules. Ex. cellule C1 on saisi oct-10 pour octobre, en D1 le produit
la formule devient
=SOMMEPROD((A1:A20=C1)*(B1:B20=D1))
dans le cas ou tu ne souhaite pas ou tu ne peux pas séparer la chaine contenue en A1 à A20
la formule serait
=SOMMEPROD((GAUCHE(A1:A20;6)="oct-10")*(DROITE(A1:A20;6)="ananas"))
si comme dans l'exemple précédent on utilise deux cellules pour saisir les critères date et produit
cellule date C1 formatée texte ou format personnalisée @ et D1 produit. ces deux cellules peuvent contenir des listes de validations pour éviter les erreurs de saisies
=SOMMEPROD((GAUCHE(A1:A20;NBCAR(C1))=C1)*(DROITE(A1:A20;NBCAR(D1))=D1))
Si tu as besoin d'un fichier exemple n'hésite pas
Romain 75009
2 mai 2012 à 10:24
Slt Mike... Merci pour tes explications... c'est vrai qu'un fichier exemple serait génial... si tu peux me le joindre ca serait le top. MERCI!!!!
0