Tableau croisé Dynamique: modifier le total général [Résolu/Fermé]

Signaler
Messages postés
16
Date d'inscription
samedi 9 mars 2013
Statut
Membre
Dernière intervention
3 avril 2013
-
Messages postés
16
Date d'inscription
samedi 9 mars 2013
Statut
Membre
Dernière intervention
3 avril 2013
-
Bonjour,

Je vous explique mon problème en espérant que vous pourrez m'aider :)
(je travaille sur excel 2010)

Je viens de créer un tableau croisé dynamique qui met en relation des dates (en lignes), des personnes (en colonnes) et des calories consommées.
Chaque jour, chacune des personnes mange à plusieurs reprises un nombre x de calories, il y a donc plusieurs nombres à additionner pour obtenir la consommation quotidienne.

Le but de ce tableau est donc d'avoir le nombre de calories mangées chaque jour par chacune des personnes, et c'est bien ce que j'obtiens en choisissant d'utiliser la somme pour résumer les valeurs du champ.
Pour cela, pas de problème!

Cependant il me faudrait également avoir la moyenne de toutes ces consommations quotidiennes, et cela par personne.
(par exemple, savoir au vu des moyennes quotidiennes, que Pierre mange en moyenne 2000 kcal par jour).

J'aimerais savoir si le total général qui s'affiche en bas de mon tableau qui est donc la sommes de toutes les consommations journalières par personne pourrait être transformé en moyenne des consommations quotidiennes.

Merci d'avance

3 réponses

Messages postés
4797
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
18 décembre 2018
3 912
Bonjour Alienna

Si je comprends bien la construction de ton TCD,
fais un clic droit sur un total /synthétiser les valeurs / Moyenne


Argitxu
5
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 66686 internautes nous ont dit merci ce mois-ci

Messages postés
16
Date d'inscription
samedi 9 mars 2013
Statut
Membre
Dernière intervention
3 avril 2013
4
Merci argixu,
mais en faisant cela je n'ai plus la somme des différentes calories consommées chaque jour, mais leur moyenne.
J'aimerais appliquer la moyenne uniquement sur la dernière ligne du tableau qui pour l'instant est un total général.
Messages postés
4797
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
18 décembre 2018
3 912
Il faudrait savoir. Tu veux la moyenne en plus ou à la place ? Tu as demandé que "la sommes de toutes les consommations journalières par personne pourrait être transformé en moyenne des consommations quotidiennes. "

Tu pourras le faire selon la construction du TCD qu'il faudrait qu'on comprenne
Sers-toi de https://www.cjoint.com/
crée le lien, copie le et colle le sur ton prochain message ici
Sans données confidentielles bien sûr
Messages postés
16
Date d'inscription
samedi 9 mars 2013
Statut
Membre
Dernière intervention
3 avril 2013
4
https://www.cjoint.com/c/CCjtt1MjGPH

Voila! Ce n'est pas le vrai fichier mais le fonctionnement est le même.
Par exemple pour Jean, j'aimerais obtenir la moyenne entre 1246 et 912, au lieu de la somme des consommations journalières (2158).

J'espère que le lien éclairera un petit peu mon problème.
Messages postés
4797
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
18 décembre 2018
3 912
Re

Tu parlais de moyenne de consommation quotidienne, d'où ma réponse, je ne voyais pas du tout ce calcul là !
Mais bon, si tu ne veux faire que la moyenne des totaux par jour,
tu ne pourras faire cette moyenne que hors TCD en dessous de chaque colonne, avec la fonction =MOYENNE(B14:B15)

Pour masquer la somme des consommations journalières : Options du TCD / totaux et filtres / décocher totaux par lignes
Messages postés
23780
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
5 janvier 2021
6 547
Bonjour,

Ton TCD serait mieux à coté que sous tes données.
Tu peux mettre la moyenne au-dessus et utiliser une plage dynamique :
=MOYENNE(DECALER(F4;;;NB($E:$E);))
https://www.cjoint.com/c/CCkjtzuoKCy

eric
Messages postés
16
Date d'inscription
samedi 9 mars 2013
Statut
Membre
Dernière intervention
3 avril 2013
4
Merci eriiic.
En fait en réalité mon TCD se trouve dans une autre feuille, c'était juste pour donner un exemple.
Et j'ai réussi à faire la moyenne grâce à une formule :)
Messages postés
16
Date d'inscription
samedi 9 mars 2013
Statut
Membre
Dernière intervention
3 avril 2013
4
Ah zut, j'avais envisagé de faire un calcul de moyenne en dessous mais j'espérais qu'une option du TCD puisse le faire.
Le truc c'est que le tableau va s'agrandir chaque jour de nouvelles lignes, donc ça sera pas trop évident pour écrire le calcul de la fonction moyenne...
Mais je te remercie, je vais creuser dans cette direction.