Excel, diviser par nb de cellules remplis

Résolu/Fermé
tonyynot - 15 avril 2012 à 19:32
 tonyynot - 15 avril 2012 à 20:26
Bonjour,
.
Alors voila j'aimerais savoir comment on divise par un nombre de cellules remplis ?
Sur une ligne allant de A1 à A10, par exemple je rentre A1=150 A2=175 A3=164 A4 à A10 reste vide.
.
Dans une nouvelle cellule je souhaite diviser un nombre que je choisis, par exemple 10 que je divise par le nombre de cellule rempli ici c'est 3
.
Une solution ?

2 réponses

Mike-31
Messages postés
17957
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
27 mai 2022
4 947
Modifié par Mike-31 le 15/04/2012 à 19:55
Salut,

Tu peux faire un calcul de moyenne directement
=MOYENNE(A1:A10)

autrement pour répondre à ta question il suffit de faire la somme
=somme(A1:A10)/NBVAL(A1:A10)

=NBVAL(A1:A10) compte le nombre de cellules renseignées

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
28