Nombre de cellule non-vide dans Nbval [Résolu/Fermé]

Signaler
-
Messages postés
52
Date d'inscription
mardi 6 novembre 2012
Statut
Membre
Dernière intervention
6 novembre 2014
-
Bonjour,

J'aimerais parvenir à compter le nombre de cellule contenant une valeur dans une plage. Cependant, je voudrais considérer le texte vide ("") comme une cellule vide et je ne peux donc pas utiliser Nbval

J'imagine qu'il est possible d'utiliser nb.si mais je ne parvient pas à écrire une formule adéquate pour le critère... exemple: Nb.si(A1:A10;<>"")

Quelle serait la façon correcte d'arriver au résultat souhaité?

Merci beaucoup


3 réponses

Messages postés
8246
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
13 novembre 2020
1 518
Bonjour,

=NB.SI(A1:A10;">""""")+NB(A1:A10)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
8246
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
13 novembre 2020
1 518
Finalement (et curieusement) il vaut mieux :

=NBVAL(A1:A10)-NB.SI(A1:A10;"< ")

(avec un espace après le <)

Curieusement parce qu'une cellule qui contient =CAR(10) devrait être ôtée, ce qui n'est pas le cas.
Messages postés
2394
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
11 novembre 2020
896
Bonjour,
Il y a peut-être aussi =NBVAL(A1:A10)-NB.VIDE(A1:A10)
puisque avec NB.VIDE Les cellules contenant des formules qui renvoient " " (texte vide) sont également comptées.
Messages postés
8246
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
13 novembre 2020
1 518
Bonjour, tontonq,

Tu as raison, ta réponse est celle qui répond très exactement à la question !

Comme quoi on se complique parfois la vie alors que la réponse est simple (surtout quand on la connais :D)

Cordialement
Patrice
Messages postés
52
Date d'inscription
mardi 6 novembre 2012
Statut
Membre
Dernière intervention
6 novembre 2014

oui mais comment systématiser ce résultat? A1:A5000
je souhaite que SI A1"" ,A2<M>,A3"" ALORS "1" en B3 (un M entre 2 cellules vides)
Puis on passe à A4 par exemple A4 "", A5 <M>,A6<M>A7"" alors "2" en B7 car deux M entre 2 cellules vides....
merci de m'aider
Messages postés
8246
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
13 novembre 2020
1 518
Bonjour ericdidier,

Pourquoi relancer ce fil RÉSOLU avec une question qui n'a rien à voir avec le sujet ???

Il faut ouvrir un nouveau sujet ! (et soit plus explicite, j'ai rien compris à ton problème)
Messages postés
52
Date d'inscription
mardi 6 novembre 2012
Statut
Membre
Dernière intervention
6 novembre 2014

bonjour
OK,c'est vrai que ma question est autre "inscrire la longueur des series"
je suis nouveau sur le forum
j'ai ouvert un autre sujet
eric
Messages postés
23630
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 novembre 2020
6 455
Bonjour,

=NB.SI(A1:A10;"><")
Ca va te paraitre étrange mais bien respecter l'ordre ><
(et non <>)

eric
Messages postés
8246
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
13 novembre 2020
1 518
ça ne compte pas les nombres.
Messages postés
23630
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 novembre 2020
6 455
exact,
donc :
=NB.SI(A1:A10;"><")+NB(A1:A10)

eric

PS: ne compte pas les cellules avec espace (?)
voir la proposition de patrice