Plusieurs plage pour Nb.si? [Fermé]

Signaler
-
Messages postés
25817
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 février 2021
-
Bonjour,

J'aimerais savoir s'il est possible d'intégrer plusieurs plages dans une seule fonction Nb.si plutôt que d'additionner plusieurs fonctions Nb.si séparées.

Par exemple, j'aimerais que la fonction m'indique le nombre de fois que je retrouve la valeur 3 dans les plages A1:A10, B1:B20 et C1:C15.

Merci beaucoup,



5 réponses

Messages postés
23887
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 février 2021
6 659
Bonjour,

Non, tu es obligé de faire la somme des nb.si()

eric
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
23887
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 février 2021
6 659
Que celui qui a mis -1 donne sa solution, ça interessera beaucoup de monde...
Messages postés
808
Date d'inscription
samedi 22 octobre 2011
Statut
Membre
Dernière intervention
13 janvier 2020
40
Ce n'est point moi
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 299
C'était moi eriiic, mais je m'étais planté, donc j'ai remis à 0.
J'ai pensé utiliser la formule NB.SI.ENS, mais ça ne correspond pas à ce que souhaite la personne.

Désolé.
Messages postés
23887
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 février 2021
6 659
Dommage, ça aurait été interessant...
Bonne journée à tous :-)
eric
Messages postés
25817
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 février 2021
5 784
Bonsoir
en fait il y a une solution, mais uniquement si vos tableaux ne risquent pas de comporter les valeurs cherchées dans les parties débordantes des plages les plus courtes
vous pouvez alors écrire:
=NB.SI(A1:C20;3)
Crdlmnt
Messages postés
808
Date d'inscription
samedi 22 octobre 2011
Statut
Membre
Dernière intervention
13 janvier 2020
40
Dans la même cellule ?
En fait, je voudrais simplement utiliser la fonction Nb.si, mais ma plage s'étend sur plusieurs colonnes différentes.

Si je reprend mon exemple précédent, la fonction Nb.si(plage;critère) peut-elle contenir une plage qui s'étend sur plusieurs colonnes? En terme de fonction, ce que je cherche à faire serait quelque chose comme ci-dessous.... mais qui fonctionnerait!
Nb.si((A1:A10;B1:B20;C1:C15);3)
Messages postés
808
Date d'inscription
samedi 22 octobre 2011
Statut
Membre
Dernière intervention
13 janvier 2020
40
Oui oui j'ai compris à peu près ton problème ...

Par exemple de A1;A10: tu as 5 trois,
de B1:B20 tu as 7 trois,
de C1:C15, tu en as 3 trois,

Tu veux affichier 5/7/3 ou alors 15 ?
J'aurais voulu afficher 15 sans avoir à faire la somme de plusieurs Nb.si.

Comme ce semble impossible, je vais donc tout de même adopter cette technique même si mes formules deviennent un peu lourdes lorsque plusieurs colonnes sont utilisées.

Merci beaucoup pour votre aide,