Problème Nagios => Check_http : erreur 401 [Résolu/Fermé]

Signaler
Messages postés
91
Date d'inscription
dimanche 2 mars 2008
Statut
Membre
Dernière intervention
23 mars 2012
-
Messages postés
91
Date d'inscription
dimanche 2 mars 2008
Statut
Membre
Dernière intervention
23 mars 2012
-
Bonjour,

Je rencontre un problème avec Nagios 3 avec le l'utilisation du Check_http.

Lorsque j'utilise ce check sur mes serveursweb, je rencontre l'erreur "HTTP WARNING: HTTP/1.1 401 Unauthorized "

Pourtant tous mes serveurs sont bien disponibles et ne demandent aucune identifications pour arriver dessus.
(seulement après une zone d'identification est affichée pour avoir accès à toutes les fonctionnalités)

Voici un aperçu du problème dans Nagios:
http://img854.imageshack.us/img854/8605/92654646.gif



Voici ma commande dans mon fichier service (celle de defaut)

# check that web services are running
define service {
        hostgroup_name                  http-servers
        service_description             Check HTTP
        check_command                   check_http
        use                             generic-service
        notification_interval           0 ; set > 0 if you want to be renotified
}


et cette commande renvoie vers :

# 'check_http' command definition
define command{
        command_name    check_http
        command_line    /usr/lib/nagios/plugins/check_http -H '$HOSTADDRESS$' -I '$HOSTADDRESS$'
        }



Merci d'avance.

4 réponses

Messages postés
29277
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 septembre 2020
6 928
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60938 internautes nous ont dit merci ce mois-ci

Messages postés
91
Date d'inscription
dimanche 2 mars 2008
Statut
Membre
Dernière intervention
23 mars 2012
24
Merci, je viens d'utiliser cette commande

check_tcp!80 mais elle n'indique pas les erreurs http hékas

J'avais auparavant une erreur 500 sur un des serveurs et elle n'est plus prise en compte :/


edit : c'est bon, ça marche nickel :) merci !
( le serveur sous erreur 500 a refonctionné entre temps)
Messages postés
29277
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 septembre 2020
6 928
Parfait ! Bonne continuation !
Messages postés
91
Date d'inscription
dimanche 2 mars 2008
Statut
Membre
Dernière intervention
23 mars 2012
24
Merci ;)