Problème Nagios => Check_http : erreur 401

Résolu/Fermé
aalex57 Messages postés 91 Date d'inscription dimanche 2 mars 2008 Statut Membre Dernière intervention 23 mars 2012 - 7 mars 2012 à 17:35
aalex57 Messages postés 91 Date d'inscription dimanche 2 mars 2008 Statut Membre Dernière intervention 23 mars 2012 - 9 mars 2012 à 09:44
Bonjour,

Je rencontre un problème avec Nagios 3 avec le l'utilisation du Check_http.

Lorsque j'utilise ce check sur mes serveursweb, je rencontre l'erreur "HTTP WARNING: HTTP/1.1 401 Unauthorized "

Pourtant tous mes serveurs sont bien disponibles et ne demandent aucune identifications pour arriver dessus.
(seulement après une zone d'identification est affichée pour avoir accès à toutes les fonctionnalités)

Voici un aperçu du problème dans Nagios:
http://img854.imageshack.us/img854/8605/92654646.gif



Voici ma commande dans mon fichier service (celle de defaut)

# check that web services are running
define service {
        hostgroup_name                  http-servers
        service_description             Check HTTP
        check_command                   check_http
        use                             generic-service
        notification_interval           0 ; set > 0 if you want to be renotified
}


et cette commande renvoie vers :

# 'check_http' command definition
define command{
        command_name    check_http
        command_line    /usr/lib/nagios/plugins/check_http -H '$HOSTADDRESS$' -I '$HOSTADDRESS$'
        }



Merci d'avance.

4 réponses

mamiemando Messages postés 32302 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 28 mars 2023 7 576
8 mars 2012 à 10:58
1
aalex57 Messages postés 91 Date d'inscription dimanche 2 mars 2008 Statut Membre Dernière intervention 23 mars 2012 25
Modifié par aalex57 le 8/03/2012 à 11:20
Merci, je viens d'utiliser cette commande

check_tcp!80 mais elle n'indique pas les erreurs http hékas

J'avais auparavant une erreur 500 sur un des serveurs et elle n'est plus prise en compte :/


edit : c'est bon, ça marche nickel :) merci !
( le serveur sous erreur 500 a refonctionné entre temps)
0
mamiemando Messages postés 32302 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 28 mars 2023 7 576
9 mars 2012 à 01:53
Parfait ! Bonne continuation !
0
aalex57 Messages postés 91 Date d'inscription dimanche 2 mars 2008 Statut Membre Dernière intervention 23 mars 2012 25
9 mars 2012 à 09:44
Merci ;)
0