Excel: Date compris entre deux dates

Résolu/Fermé
gladou67
Messages postés
13
Date d'inscription
jeudi 23 février 2012
Statut
Membre
Dernière intervention
27 mars 2013
- 23 févr. 2012 à 13:22
gladou67
Messages postés
13
Date d'inscription
jeudi 23 février 2012
Statut
Membre
Dernière intervention
27 mars 2013
- 24 févr. 2012 à 08:09
Bonjour,

Je souhaiterai savoir si une date est comprise entre deux autres en faisant abstraction des jours (donc en ne prenant que les mois et années en compte).
J'ai réalisé une formule qui marche avec les jours mais comme les statistiques sont réalisées par mois elle n'est donc pas utilisable:

=SI(ET(présent>F2;présent<H2);"OUI";"NON")
F2 Date de début
H2 Date de fin
présent = date du jours

Ce que je voudrais c'est pouvoir dire si une personne était présente un mois donné sans tenir compte du jours (si elle est la le 1er février alors elle est considéré comme ayant été la tout le mois de février).

Or si je rajoute du MOIS() dans ma formule il ne prend que les mois et il me dira que février 2012 n'est pas compris entre mars 2011 et juin 2012 car 2 n'est pas compris entre 3 et 6.

Quelle fonction puise-je utiliser?


A voir également:

8 réponses

Mike-31
Messages postés
18048
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
19 septembre 2022
4 992
23 févr. 2012 à 15:35
Salut,

la date présence en C1 cette formule te donnera la différence entre cette date et le premier jour du mois, il faut formater la cellule en standard

=C1-FIN.MOIS(C1;-1)
2