Excel: Date compris entre deux dates [Résolu/Fermé]

Signaler
Messages postés
13
Date d'inscription
jeudi 23 février 2012
Statut
Membre
Dernière intervention
27 mars 2013
-
Messages postés
13
Date d'inscription
jeudi 23 février 2012
Statut
Membre
Dernière intervention
27 mars 2013
-
Bonjour,

Je souhaiterai savoir si une date est comprise entre deux autres en faisant abstraction des jours (donc en ne prenant que les mois et années en compte).
J'ai réalisé une formule qui marche avec les jours mais comme les statistiques sont réalisées par mois elle n'est donc pas utilisable:

=SI(ET(présent>F2;présent<H2);"OUI";"NON")
F2 Date de début
H2 Date de fin
présent = date du jours

Ce que je voudrais c'est pouvoir dire si une personne était présente un mois donné sans tenir compte du jours (si elle est la le 1er février alors elle est considéré comme ayant été la tout le mois de février).

Or si je rajoute du MOIS() dans ma formule il ne prend que les mois et il me dira que février 2012 n'est pas compris entre mars 2011 et juin 2012 car 2 n'est pas compris entre 3 et 6.

Quelle fonction puise-je utiliser?


A voir également:

8 réponses

Messages postés
17408
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 juillet 2021
4 668
Salut,

la date présence en C1 cette formule te donnera la différence entre cette date et le premier jour du mois, il faut formater la cellule en standard

=C1-FIN.MOIS(C1;-1)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
26102
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 juillet 2021
5 989
Bonjour
on ne comprend pas votre problème
si F2 date début et H2 date de fin correspondent bien au 1° jour du mois début et au dernier du mois de fin.. ou est votre question?
crdlmnt


Messages postés
13
Date d'inscription
jeudi 23 février 2012
Statut
Membre
Dernière intervention
27 mars 2013

Ce sont des dates de début et de fin de contrats mais ce ne sont pas des dates de début et de fin de mois. Un employé peut commencé le 14 avril et finir le 5 octobre.

J'aimerais que quand je saisis une date de fin de mois dans la cellule "présent"
il me dise combien de jours cette personne à travaillé ce mois-ci.

Or si je met en date le 30 mai pour la personne qui a commencé à travaillé le 14 avril il me fera la différence entre le 30 mai et le 14 avril. N'y a t'il pas un moyen de ne lui faire compter que les jours du moi saisi dans la case "présent" (en l'occurence il me dirait 30 jours et pas 30 + les jours d'avril).

J'avoue que la formulation que j'ai faite avant était ambiguie et je m'en excuse.
Messages postés
1440
Date d'inscription
jeudi 3 octobre 2002
Statut
Contributeur
Dernière intervention
5 janvier 2013
121
Bonjour,

Si ce que tu veux, c'est juste une réponse de type oui/non, je te propose ceci :

=SI(ET(MOIS(present)>=MOIS(dateDebut);MOIS(present)<MOIS(dateFin)+1);"OUI";"NON")

ex :
date début = 01/02/2012
date fin = 15/04/2012

present = 15/01/2012 => NON
present = 01/02/2012 => OUI
present = 23/02/2012 => OUI
present = 15/04/2012 => OUI
present = 28/04/2012 => OUI
present = 01/05/2012 => NON

C'est ce que tu souhaites ?
Messages postés
13
Date d'inscription
jeudi 23 février 2012
Statut
Membre
Dernière intervention
27 mars 2013

Merci pour les formules. J'ai fait un petit tableau avec les dates de début et de fin et ce que je voudrais, c'est plus clair.

Comme je n'ai pas trouvé comme inclure un fichier, je met un lien vers dl free pour le télécharger.

http://dl.free.fr/getfile.pl?file=/jki4k90d
Messages postés
24137
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 juillet 2021
6 842
Bonsoir,

Ta demande dans le fichier ne correspond pas à ta demande du 1er post (???)

Pour ta demande du 1er post :
=ET(ANNEE(présent)*100+MOIS(présent)>=ANNEE(B4)*100+MOIS(B4);ANNEE(présent)*100+MOIS(présent)<=ANNEE(C4)*100+MOIS(C4))
à recopier vers le bas

Retourne VRAI/FAUX, tu peux completer par un test si tu veux une autre réponse.

eric
Messages postés
13
Date d'inscription
jeudi 23 février 2012
Statut
Membre
Dernière intervention
27 mars 2013

effectivement la formule est fonctionnelle et affiche bien si l'agent était présent dans le mois! merci beaucoup. Cependant je ne comprends pas la formule (surtout les *100 en fait).
Messages postés
24137
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 juillet 2021
6 842
Pour tenir compte de l'année et du mois : multiplier l'année par 100 (2012*100=201200) et additionner le mois (201200+08=201208) pour les dates ce qui permet de les comparer sans tenir compte du jour dans le mois.
eric
Messages postés
13
Date d'inscription
jeudi 23 février 2012
Statut
Membre
Dernière intervention
27 mars 2013

d'accord, ça permet d'éviter la conversion en "vrai format date", celui où il compte à partir de 01/01/1900. Merci pour le tuyaux.
Et pour compter les jours travaillés comme dans l'exemple, on peut faire comment?