Alerte sécurité et liens hypertexte [Fermé]

Signaler
Messages postés
3
Date d'inscription
dimanche 5 février 2012
Statut
Membre
Dernière intervention
6 février 2012
-
Messages postés
11
Date d'inscription
lundi 25 janvier 2010
Statut
Membre
Dernière intervention
17 avril 2020
-
Bonjour à tous,

Je vous soumets un petit problème, mais très très très gênant au quotidien, et pour lequel je ne trouve aucune solution.

Voici le problème : je possède sur mon PC (sous windows 7) les suites Office 2010 et OpenOffice 3.3. Dans un classeur Excel, j'ai inséré des liens hypertexte vers des documents OpenOffice ; lorsque je clique sur ces liens, une alerte de sécurité apparaît ("Certains fichiers peuvent contaminer... Voulez-vous continuer ?"). Le problème est identique dans tous les logiciels de la suite Office 2010, et seulement pour les logiciels OpenOffice.
J'ai testé TOUTES les solutions que j'ai pu glaner sur internet, mais aucune n'a fonctionné et le problème est toujours présent :

* modification des clés de registre pour désactiver les messages d'alerte d'Office 2010 ;
* modifications des paramètres d'Internet Explorer, y compris le fait de le mettre comme navigateur par défaut ;
* inscription des documents OpenOffice comme "documents" et "emplacements approuvés" (plus tous les autres paramètres possibles dans le "centre de gestion de la confidentialité"), dans les paramètres d'Office ;
* désinstallation et réinstallation d'OpenOffice.


Dans cette liste, j'ai sans doute oublié deux ou trois petites choses, j'en suis désolé...
Il est bon de signaler que ce problème est survenu subitement, sans que j'aie le souvenir d'avoir modifié quoi que ce soit d'important dans les paramètres de Windows 7 ou d'Office.
La dernière chose qui peut avoir du sens pour les connaisseurs tient dans le fait que ce problème ne se manifeste pas lorsque j'ouvre, en tant qu'utilisateur "invité" (donc avec des paramètres différents de ceux de l'administrateur), les mêmes documents, qui sont alors en lecture seule ; en revanche, lorsque je crée un document en tant qu'invité, le même message d'alerte s'ouvre lorsque je clique sur le lien vers document OpenOffice.

C'est un problème apparemment anodin, mais lorsqu'on a à cliquer une cinquantaine de fois par jour sur ces fameux liens, c'est réellement agaçant (pour ne pas dire autre chose...).

Quels sont donc les paramètres à modifier ou les manipulations à faire pour arrêter ces alertes ??

Mon message est très long (pardon !), mais j'aimerais vraiment solutionner ce petit truc, qui est comme un moustique dans une chambre qui vole toute la nuit et qu'on n'arrive pas à attraper...


Merci déjà d'avoir lu jusqu'ici et, pourquoi pas, de proposer un début de solution.


Patane24.


9 réponses

72 € si je veux de l'aide chez support.microsoft.com (pour un produit qui en a coûté ~ 100)... dommage !

Bon, RÉSOLU de mon côté, après avoir lu beaucoup de suggestions pendant près d'une heure, en anglais comme en français (souvent des pas-à-pas obsolètes, erronés ou inapplicables), et presque tout tenté (à part réinstaller et corrompre mon Registre). Je ne remercie pas Microsoft (answers.microsoft.com, le FixIt etc.), ni Adobe (les conversions d'Office en Pdf avaient le même souci) [ni encore les mauvais informaticiens/bloggeurs en herbe qui peuplent le web pour rendre nos systèmes encore plus instables) !

Alors un grand MERCI à **lapin** et à **Mysticlo** (et dans une moindre mesure à Diane de slipstick.com) pour nous avoir rappelé l'importance du système minable des "EditFlags" (lapin, votre lien d'explicatif a disparu). [L'ennuyeux avec ces modifications manuelles du Registre, c'est que chaque fois qu'une association d'extension de fichier bloque, elle doit être éditée à la main, ce qui peut devenir fastidieux sans script...]


Alors voilà ce que je retiendrai concernant mon problème + sa solution :

1. mon fichier Excel a des milliers de liens vers des fichiers locaux (= du disque dur)

2. les présentes informations sont applicables avec tous les produits Office (et Windows)

3. mes fichiers locaux s'ouvrent bien sûr normalement (= sans alerte) si je ne passe pas par Excel/Office

4. modifier les droits d'accès, comme les paramètres Internet (dont Internet Explorer) est inutile

5. commençons par ouvrir l'éditeur du Registre Windows (on peut exécuter "regedit")

6. si vous avez la moindre crainte de provoquer des pannes - parfois graves - du système (il y en a d'autant plus que vous débutez avec RegEdit), sauvegardez maintenant votre Registre : pour la totalité de celui-ci, cliquez "Ordinateur", puis clic droit, puis Exporter, puis nommez votre fichier (*.Reg), puis Enregistrez

7. sous "HKEY_CLASSES_ROOT", aller à la clé qui correspond exactement à votre extension de fichier (Mysticlo a indiqué comment rechercher rapidement cette courte chaîne de caractères, mais pensez à bien recliquer "Ordinateur" à chaque nouvelle recherche intégrale)

8. sous le nom "(par défaut)" vous trouvez la donnée qui vous concerne (elle est de type "REG_SZ", naturellement sous la colonne "Données")

9. je vous conseille de copier cette valeur : clic droit sur "(par défaut)", puis Modifier, puis Ctrl+C (ou nouveau clic droit sur la sélection, puis copier), avant de sortir via Annuler (ne modifiez pas cette clé !)

10. seconde (et dernière) recherche de clé : cliquez "Ordinateur" (= racine du Registre), puis Ctrl+F (ou menu Edition, puis Rechercher) en ne cochant que "Clés", puis collez-y votre clé, puis "Rechercher le suivant"

11. patientez un court instant, et vous tombez nécessairement sur cette fameuse clé (donc impossible de la créer - aucun doublon possible), dont vous devez libérer l'ouverture (à nouveau, vous êtes responsable de cette désactivation de la notification de sécurité)...

12. cas n°1 : à la racine (= au niveau) de votre clé, il y a déjà, au même niveau que "(par défaut)" (donc sous ce nom par défaut), la chaîne "EditFlags"... Dans ce cas, sélectionnez cette dernière, puis clic droit, puis Modifier, puis entrez (ou collez) "10000" en Hexadécimal (par défaut, ou "65536" si vous avez préféré cocher la base "Décimale" au préalable), puis OK et c'est réparé

13. cas n°2 : à la racine (= au niveau) de votre clé, il manque, au même niveau que "(par défaut)" (donc sous la colonne Nom), la chaîne "EditFlags"... Dans ce cas, sélectionnez votre clé (si elle ne l'était pas déjà), puis clic droit, puis Nouveau, puis "Valeur DWORD 32 bits", puis nommez celle-ci "EditFlags", avant de poursuivre (à l'identique de la fin du point 12 précédent, c'est-à-dire) : sélectionnez "EditFlags", puis clic droit, puis Modifier, puis entrez (ou collez) "10000" en Hexadécimal (par défaut, ou "65536" si vous avez préféré cocher la base "Décimale" au préalable), puis OK et c'est réparé.


Bon courage à toutes et à tous !
DP
8
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 66686 internautes nous ont dit merci ce mois-ci

j'ai eu ce problème avec Excel et des liens hypertextes vers des vidéo. j'ai essayé la solution http://support.microsoft.com/kb/925757/fr sans succès. En faite mes vidéos sont lu avec VLC. c'est en faisant pleins d'essais dans la base de registre que j'ai trouvé la solution.

Le sésame est l'ajout de la valeur DWORD 32
nommé "EditFlags"
valeur Hexadécimale = 10000 au bon endroit.

Pour moi c'était ici [HKEY_CLASSES_ROOT\VLC.mp4] et [HKEY_CLASSES_ROOT\VLC.avi] car j'avais les 2 extensions (.mp4 et .avi) dans mon fichier excel.

Dans ton cas il va falloir trouver la bonne clé de registre. Ouvre regedit et tu lance une recherche "odt" uniquement en cochant "clé" sans cocher les autres ni "mot entier seulement".

Tu dois tomber sur [é sur un lien avec un fichier *.odt.
HKEY_CLASSES_ROOT\odtfile] place ta nouvelle valeur dword ici et essaie de cliqu
Si cela ne fonctionne pas, tu dois chercher la bonne clé, qui sera toujours dans HKEY_CLASSES_ROOT, pas la peine d'aller dans les autres clé principales.


ma config windows seven et Microsoft office-2010.
Il faut télécharger le "fix it" MS 50681.

l'appliquer.

PUIS,

à modifier la base de registre de manière similaire à la solution n°2 de microsoft. seulement, il ne faut pas mettre le EditFlag sur le type de fichier (wmvfile) mais sur le type de fichier associé à un programme. Je m'explique, dans la base de registre, dans la section HKEY_CLASSES_ROOT vous trouverez des sous clés du type "VLC.avi" ou "mplayerc.wmv" qui correspondent à la manière dont le système doit considérer l'ouverture de ces fichiers (ici un .avi et un .wmv) avec différents types de programmes (ici, VLC et Media Player Classic). Il suffit donc de dire à Windows que ces associassions programmes.fichiers sont sûrs grâce à un EditFlags (plus d'infos sur le EditFlags ici)
Par exemple pour ne plus avoir de message d'avertissement lors de l'ouverture d'un fichier mpg avec VLC, il faut ajouter à la sous clef:
HKEY_CLASSES_ROOT\VLC.mpg
la valeur de type DWORD "EditFlags"
et la mettre à 10000 en héxa (65536 en décimal).

MAGIC, on a plus de message d'erreur.
Alors un grand MERCI à **lapin** et à **Mysticlo**

je suis content que cela t'ai servis.
Pour ma part cette solution manuelle fonctionne mais ne dur pas dans la temps.
A chaque mise a jour de VLC, je dois rentrer à nouveau les valeurs dans la base de registre.
C'est pourquoi j'ai exporté ses clés dans un fichier.reg que je relance après chaque mise a jour de VLC afin ne pas les retaper à la main. Un double clic suffi ;)

je t'invite à faire de même avec tous tes ajouts "EditFlags" dans les clés concernées.

Ex de mon fichier reg pour office 2010:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Security]
"DisableHyperlinkWarning"=dword:00000001

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Common\Security]
"DisableHyperlinkWarning"=dword:00000001


[HKEY_CLASSES_ROOT\VLC.mp4]
"EditFlags"=dword:00010000

[HKEY_CLASSES_ROOT\VLC.avi]
"EditFlags"=dword:00010000

[HKEY_CLASSES_ROOT\VLC.mpg]
"EditFlags"=dword:00010000

[HKEY_CLASSES_ROOT\VLC.3gp]
"EditFlags"=dword:00010000
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
831
Salut le forum

Voir le lien : ... messages d'avertissement de lien hypertexte ...

Mytå
Messages postés
3
Date d'inscription
dimanche 5 février 2012
Statut
Membre
Dernière intervention
6 février 2012

Merci bien pour cette réponse, que je connaissais déjà, mais, je dois l'avouer, pas entièrement...

Le site de Microsoft a été en effet le premier "secours" que j'avais tenté, avec la solution "FixIt", puis la modification des clés de registre. Ni l'une ni l'autre n'ont marché.

J'ai donc été un peu plus attentif aux indications de Microsoft au sujet des guillemets, puisqu'ils sont absents dans le message d'alerte : je me suis donc dit que le problème pouvait provenir de HLINK.dll.
J'ai trouvé ces fichiers sur mon PC (à 4 endroits différents), mais le tout petit informaticien que je suis n'a pas réussi à tirer quelque renseignement que ce soit sur la sécurité de ce fichier ; de plus, j'ai constaté qu'il est absolument impossible de faire quoi que ce soit avec ce fichier (Copier/Coller....), puisque c'est TrustedInstaller qui en est le propriétaire.
J'ai malgré tout tenté de franchir ce blocage en installant "Unlocker" puis en téléchargeant le fichier HLINK d'origine. Quelques manipulations ont été possibles, mais le résultat est toujours nul et les messages d'alerte arrivent encore !...
En dernier recours, j'ai donc tenté de désinstaller Office 2010 puis de le réinstaller. Le problème n'a pas changé.
Donc, lorsque je dis avoir essayé toutes les solutions, je ne mens pas vraiment...
Réinstaller Windows pourrait être une solution, mais cela me paraît un peu excessif et risqué !
Le problème me paraît de plus en plus insoluble...

Merci quand même de vous torturer les méninges et de me proposer éventuellement une solution que je n'aurais pas essayée. Bon courage !!!!!!!!!
Messages postés
3
Date d'inscription
dimanche 5 février 2012
Statut
Membre
Dernière intervention
6 février 2012

Une petite précision supplémentaire qui pourrait aider ceux qui auraient le courage de vouloir résoudre mon problème.
En effet, ayant momentanément désinstallé OpenOffice avant de le réinstaller, j'ai constaté que cliquer sur les fameux liens hypertextes d'Excel vers des documents OpenOffice me fournissait toujours les mêmes avertissements.
Si ma logique raisonne correctement, c'est donc que toutes les extensions propres à des documents OpenOffice (odt...) ou proches ne sont pas "approuvées" ou reconnues comme sûres par Office et/ou Windows 7
Ma question évolue donc un peu : comment faire pour que OpenOffice et ses documents soient reconnus par Windows 7 et Office 2010 ?
Idem, rien ne fonctionne !
Messages postés
11
Date d'inscription
lundi 25 janvier 2010
Statut
Membre
Dernière intervention
17 avril 2020
11
Bonjour à tous
Voilà, moi aussi j'ai ce problème.
J'ai un gros fichier Excel avec pleins de liens vers des fichiers mp3 et des fichiers pdf. Naturellement, chaque fois que je veux ouvrir un fichier pdf (avec Foxit Reader) ou un fichier mp3 (avec wmplayer), j'ai ce message d'avertissement.
Je voudrais essayer la méthode indiquée, mais j'ai un peu de mal. J'ai du mal à comprendre quelle clé, il faut trouver.
Par exemple, pour les mp3 : est-ce que dois trouver sous HKEY_CLASSES_ROOT la cle wmplayer.mp3 ? Pour ma part, je ne la trouve pas. Je trouve seulement wmplayer.exe. Par contre, je trouve bien une clé VLC.mp3. Mais bon, je n'utilise pas VLC.
Est-ce que quelqu'un pourrait m'aider ?
Marci