Alerte sécurité et liens hypertexte

Fermé
Patane24 Messages postés 3 Date d'inscription dimanche 5 février 2012 Statut Membre Dernière intervention 6 février 2012 - 5 févr. 2012 à 01:01
malbousquet Messages postés 17 Date d'inscription lundi 25 janvier 2010 Statut Membre Dernière intervention 6 août 2022 - 22 sept. 2014 à 18:20
Bonjour à tous,

Je vous soumets un petit problème, mais très très très gênant au quotidien, et pour lequel je ne trouve aucune solution.

Voici le problème : je possède sur mon PC (sous windows 7) les suites Office 2010 et OpenOffice 3.3. Dans un classeur Excel, j'ai inséré des liens hypertexte vers des documents OpenOffice ; lorsque je clique sur ces liens, une alerte de sécurité apparaît ("Certains fichiers peuvent contaminer... Voulez-vous continuer ?"). Le problème est identique dans tous les logiciels de la suite Office 2010, et seulement pour les logiciels OpenOffice.
J'ai testé TOUTES les solutions que j'ai pu glaner sur internet, mais aucune n'a fonctionné et le problème est toujours présent :

* modification des clés de registre pour désactiver les messages d'alerte d'Office 2010 ;
* modifications des paramètres d'Internet Explorer, y compris le fait de le mettre comme navigateur par défaut ;
* inscription des documents OpenOffice comme "documents" et "emplacements approuvés" (plus tous les autres paramètres possibles dans le "centre de gestion de la confidentialité"), dans les paramètres d'Office ;
* désinstallation et réinstallation d'OpenOffice.


Dans cette liste, j'ai sans doute oublié deux ou trois petites choses, j'en suis désolé...
Il est bon de signaler que ce problème est survenu subitement, sans que j'aie le souvenir d'avoir modifié quoi que ce soit d'important dans les paramètres de Windows 7 ou d'Office.
La dernière chose qui peut avoir du sens pour les connaisseurs tient dans le fait que ce problème ne se manifeste pas lorsque j'ouvre, en tant qu'utilisateur "invité" (donc avec des paramètres différents de ceux de l'administrateur), les mêmes documents, qui sont alors en lecture seule ; en revanche, lorsque je crée un document en tant qu'invité, le même message d'alerte s'ouvre lorsque je clique sur le lien vers document OpenOffice.

C'est un problème apparemment anodin, mais lorsqu'on a à cliquer une cinquantaine de fois par jour sur ces fameux liens, c'est réellement agaçant (pour ne pas dire autre chose...).

Quels sont donc les paramètres à modifier ou les manipulations à faire pour arrêter ces alertes ??

Mon message est très long (pardon !), mais j'aimerais vraiment solutionner ce petit truc, qui est comme un moustique dans une chambre qui vole toute la nuit et qu'on n'arrive pas à attraper...


Merci déjà d'avoir lu jusqu'ici et, pourquoi pas, de proposer un début de solution.


Patane24.


A voir également:

9 réponses

72 € si je veux de l'aide chez support.microsoft.com (pour un produit qui en a coûté ~ 100)... dommage !

Bon, RÉSOLU de mon côté, après avoir lu beaucoup de suggestions pendant près d'une heure, en anglais comme en français (souvent des pas-à-pas obsolètes, erronés ou inapplicables), et presque tout tenté (à part réinstaller et corrompre mon Registre). Je ne remercie pas Microsoft (answers.microsoft.com, le FixIt etc.), ni Adobe (les conversions d'Office en Pdf avaient le même souci) [ni encore les mauvais informaticiens/bloggeurs en herbe qui peuplent le web pour rendre nos systèmes encore plus instables) !

Alors un grand MERCI à **lapin** et à **Mysticlo** (et dans une moindre mesure à Diane de slipstick.com) pour nous avoir rappelé l'importance du système minable des "EditFlags" (lapin, votre lien d'explicatif a disparu). [L'ennuyeux avec ces modifications manuelles du Registre, c'est que chaque fois qu'une association d'extension de fichier bloque, elle doit être éditée à la main, ce qui peut devenir fastidieux sans script...]


Alors voilà ce que je retiendrai concernant mon problème + sa solution :

1. mon fichier Excel a des milliers de liens vers des fichiers locaux (= du disque dur)

2. les présentes informations sont applicables avec tous les produits Office (et Windows)

3. mes fichiers locaux s'ouvrent bien sûr normalement (= sans alerte) si je ne passe pas par Excel/Office

4. modifier les droits d'accès, comme les paramètres Internet (dont Internet Explorer) est inutile

5. commençons par ouvrir l'éditeur du Registre Windows (on peut exécuter "regedit")

6. si vous avez la moindre crainte de provoquer des pannes - parfois graves - du système (il y en a d'autant plus que vous débutez avec RegEdit), sauvegardez maintenant votre Registre : pour la totalité de celui-ci, cliquez "Ordinateur", puis clic droit, puis Exporter, puis nommez votre fichier (*.Reg), puis Enregistrez

7. sous "HKEY_CLASSES_ROOT", aller à la clé qui correspond exactement à votre extension de fichier (Mysticlo a indiqué comment rechercher rapidement cette courte chaîne de caractères, mais pensez à bien recliquer "Ordinateur" à chaque nouvelle recherche intégrale)

8. sous le nom "(par défaut)" vous trouvez la donnée qui vous concerne (elle est de type "REG_SZ", naturellement sous la colonne "Données")

9. je vous conseille de copier cette valeur : clic droit sur "(par défaut)", puis Modifier, puis Ctrl+C (ou nouveau clic droit sur la sélection, puis copier), avant de sortir via Annuler (ne modifiez pas cette clé !)

10. seconde (et dernière) recherche de clé : cliquez "Ordinateur" (= racine du Registre), puis Ctrl+F (ou menu Edition, puis Rechercher) en ne cochant que "Clés", puis collez-y votre clé, puis "Rechercher le suivant"

11. patientez un court instant, et vous tombez nécessairement sur cette fameuse clé (donc impossible de la créer - aucun doublon possible), dont vous devez libérer l'ouverture (à nouveau, vous êtes responsable de cette désactivation de la notification de sécurité)...

12. cas n°1 : à la racine (= au niveau) de votre clé, il y a déjà, au même niveau que "(par défaut)" (donc sous ce nom par défaut), la chaîne "EditFlags"... Dans ce cas, sélectionnez cette dernière, puis clic droit, puis Modifier, puis entrez (ou collez) "10000" en Hexadécimal (par défaut, ou "65536" si vous avez préféré cocher la base "Décimale" au préalable), puis OK et c'est réparé

13. cas n°2 : à la racine (= au niveau) de votre clé, il manque, au même niveau que "(par défaut)" (donc sous la colonne Nom), la chaîne "EditFlags"... Dans ce cas, sélectionnez votre clé (si elle ne l'était pas déjà), puis clic droit, puis Nouveau, puis "Valeur DWORD 32 bits", puis nommez celle-ci "EditFlags", avant de poursuivre (à l'identique de la fin du point 12 précédent, c'est-à-dire) : sélectionnez "EditFlags", puis clic droit, puis Modifier, puis entrez (ou collez) "10000" en Hexadécimal (par défaut, ou "65536" si vous avez préféré cocher la base "Décimale" au préalable), puis OK et c'est réparé.


Bon courage à toutes et à tous !
DP
10