Liste déroulante avec saisie sous excel 2003 [Résolu/Fermé]

Signaler
-
Messages postés
53600
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
11 avril 2021
-
Bonjour,

Etant un peu néophite en tableur je cherche à faire dans le cadre d'un projet personnel à faire une colonne dont les différentes lignes seraient un menu déroulant avec un choix X et Y.

La valeur X surlignant la cellule en Orange
Le valeur Y surlignant la cellule en Vert

Jusqu'ici pas de souci, mais après ça se complique. J'aimerai que ces choix entraine la saisi d'une date remplaçant les valeurs X et Y, tout en gardant la couleur de surlignage précédemment établie.

"X" devient une date surlignée en orange
"Y" devient une date surlignée en vert

je sais pas si c'est très clair, j'espère que vous pourrez répondre à ma demande.

cdlt,

Benoit

1 réponse

Messages postés
53600
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
11 avril 2021
15 648
Bonjour.

Remplacer le contenu d'une cellule par un autre n'est possible qu'avec une macro (à créer sous VBA).

Si tu veux te contenter de formules, il faut ajouter une colonne, avec une formule du style =SI(B2="X";date1;SI(B2="Y"; date2;""))

Cordialement.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

oui c'est bien ce qui me semblait, je pense je vais finir sur la deuxième solution, mème si je voulais réduire le nombre de colonne.

Merci de votre réponse.
Messages postés
53600
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
11 avril 2021
15 648
Tu pourras toujours masquer les colonnes inutiles pour l'impression.
Tu peux déjà choisir la police Arial Narrow ou Agency FB et la taille 8 pour la colonne des X et Y ...