[boot] win xp /linux

[Fermé]
Signaler
-
Messages postés
30127
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
24 septembre 2021
-
Bonjour


J'ai installé sur deux partitions distinctes win xp dans 1 er temps et ensuite linux mandriva 2006 dans un second temps de façon à avoir un menu me permettant de me loguer soit sur linux soit sur win xp.

Malheureusement j'ai été amené à reinstaller win xp. Du coup, ben je n'ai plus accés au menu quand je démarre ma bécane !

Est-ce que je suis obligé de reinstaller linux?

Merci d'avance de vos conseils !

3 réponses

Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 554
Salut,

Est-ce que je suis obligé de reinstaller linux?

Non.

Regarde ici probleme de lancement de mandriva linux 2006#1

lami20j
J'ai suivi tes conseils.

J'ai donc mis le cd1 d'installation de mandriva 2006. J'appuis sur F1 et ensuite lance l'option pour reinstaller lilo.
Mais là ça bug, il me lance message d'erreur et veut pas me reconfigurer lilo.

Pkoi ?

P.S : Je referais un post avec le message d'erreur !
Messages postés
30127
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
24 septembre 2021
7 175
Sinon tu peux booter sur un liveCD (par exemple knoppix) et faire ce qui suit. Tout d'abord on repére la partition / avec cfdisk ou fdisk :
cfdisk /dev/hda

                                                          cfdisk 2.12r

                                                      Disk Drive: /dev/hda
                                                Size: 82348277760 bytes, 82.3 GB
                                      Heads: 255   Sectors per Track: 63   Cylinders: 10011

      Name               Flags              Part Type        FS Type                    [Label]                Size (MB)
 -------------------------------------------------------------------------------------------------------------------------------
      hda1               Boot                Primary         NTFS                                                5239,51
      hda3                                   Primary         Linux ext3                 [/]                     76593,81
      hda2                                   Primary         Linux swap / Solaris                                 509,97

Si ça ne donne rien avec /dev/hda essaye /dev/hdb, /dev/hdc ... /dev/sda, /dev/sdb .... Ici par exemple, / correspond à /dev/hda3 et est en ext3, ce qui donne :
mkdir -p /mnt/linux
mount -t ext3 /dev/hda3 /mnt/linux
cd /mnt/linux
chroot /mnt/linux
nano /etc/lilo.conf    <--------- si nécessaire (ctrl x pour quitter)
lilo
exit
cd /
umount /mnt/linux
reboot

Bonne chance