Vba ActiveCell.Formula

Résolu/Fermé
tchernosplif Messages postés 600 Date d'inscription dimanche 8 novembre 2009 Statut Membre Dernière intervention 21 juin 2015 - 27 nov. 2011 à 13:29
gbinforme Messages postés 14935 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 - 27 nov. 2011 à 23:05
Bonjour,

Je n'arrive pas pas à écrire une macro correctement (excel 2003)

au départ j'avais la formule ci-dessus qui fonctionnait bien ...

ActiveCell.Formula = "=concat(A1:AZ10)"
(la formule concat est une formule sur-mesure)

Je cherche à mettre cette formule dans un si,ce qui donne:
=si(gauche(concat(A1:AZ10);6)="<br />";"";concat(A1:AZ10))

je crois qu'il faut doubler les double quotes, j'ai donc essayé:
ActiveCell.Formula = "=si(gauche(concat(A1:AZ10);6)=""<br />"";"""";concat(A1:AZ10))"

mais ça ne fonctionne pas

Pourriez-vous maider ?
merci d'avance pour votre aide.

A voir également:

4 réponses

gbinforme Messages postés 14935 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 639
27 nov. 2011 à 22:49
bonjour,

Tu devrais essayer en bon Français :

ActiveCell.FormulaLocal = "=SI(GAUCHE(concat(A1:AZ10);6)=""<br />"";"""";concat(A1:AZ10))"
1
gbinforme Messages postés 14935 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 639
27 nov. 2011 à 23:05
ou alors il faut remplacer les ";" par "," :

ActiveCell.Formula = "=IF(LEFT(concat(A1:AZ10),6)=""<br />"","""",concat(A1:AZ10))"
0