Problème php

Fermé
rami - 19 nov. 2011 à 10:25
maka54
Messages postés
699
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
4 décembre 2016
- 19 nov. 2011 à 12:01
Bonjour,

Je voudrais développer un site en php avec smarty et adodb .
D'après ce que j ai compris il faut inclure ces 2 librairy dans le fichier php.ini ,ce que je fais mais pourtant le navigateur me donne toujours la même erreur :

Warning: require_once(Smarty.class.php) [function.require-once]: failed to open stream: Aucun fichier ou dossier de ce type in /opt/lampp/htdocs/xampp/site/Site de vente/Index.php on line 4

Fatal error: require_once() [function.require]: Failed opening required 'Smarty.class.php' (include_path='/opt/lampp/lib/php/includes/adodb/adodb.inc.php:/opt/lampp/lib/php/includes/libs/Smarty.class.php') in /opt/lampp/htdocs/xampp/site/Site de vente/Index.php on line 4

Je tourne sous Kubuntu j 'ai donc modifier la ligne 790 de php.ini j ai mis ca :

;UNIX: "/path1:/path2"
include_path = "/opt/lampp/lib/php/includes/adodb/adodb.inc.php:/opt/lampp/lib/php/includes/libs/Smarty.class.php"


J ai bien redémarré xampp avant de ré essayé et oui les dossiers sont bien au bonne endroit. Perso je pense que j'ai mal modifier le php.ini mais je vois pas quoi mettre d'autre des idées ?


1 réponse

maka54
Messages postés
699
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
4 décembre 2016
80
19 nov. 2011 à 12:01
Bonjour,

A mon avis de ne devrais pas installer de cette manière, mais simplement le placer dans ton projet "Site de vente"

je me suis déjà servi de smarty à plusieurs reprises, je n'ai jamais eu besoin de faire ces manipulations
simplement dézipper smarty dans mon projet

par contre je travaillais sous windows, peut etre qu'avec linux, l'installation est différente, là desus je ne peux pas te renseigner
0