[easyphp] le port (80)occupé par inetinfo.exe [Résolu/Fermé]

Signaler
Messages postés
9
Date d'inscription
vendredi 28 juillet 2006
Statut
Membre
Dernière intervention
3 août 2006
-
 abdellatif90 -
[débutante] Bonjour tout le monde

j ai installé easyphp mais apacha ne fonctionne ps, il me signale que le port (80) est utilisé par inetinfo.exe

j ai fait des recherche et j ai eu la reponse suivante:

Citation:
Le processus inetinfo.exe (inetinfo signifiant Internet
Information Service) est un processus générique de Windows
NT/2000/XP correspondant au serveur web IIS (Microsoft
Information Server).

Il s'agit d'un processus système pouvant être arrêté.

Cela veut dire que tu à IIS qui tourne qui est lui aussi un serveur
Web.

Essaye la manipulation suivante :
- Ctrl + Alt + Suppr
- Gestionnaire des tache
- Onglet processus
- Selectionner inetinfo.exe
-Appuyer sur terminer le processus



alors j ai suivi la demarche indiqué mais cela ne marche pas et le processus inetinfo.exe est tjrs là ds Onglet processus

merci pour votre aide

20 réponses


Si c'est un service tu peux faire

Demarrer > Executer
Tape services.msc (ou service.msc) puis Entrée
Trouve le service correspondant et arrête le.
11
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
3668
Date d'inscription
jeudi 16 juin 2005
Statut
Membre
Dernière intervention
11 janvier 2021
981 > Benjamin
Oui mais le problème, c'est que si tu l'arrêtes, tu perds ton serveur IIS ! Enfin, peut-être que tu ne t'en sers pas...
Il est à mon avis beaucoup plus simple de modifier le port d'écoute de Apache...
Pour ce faire, il faut modifier le fichier httpd.conf situé dans le répertoire Apache/conf de easyphp. Le but étant, dans ce fichier, de rechercher les occurences de "80" (le port par défaut), et de le remplacer par un port de ton choix (de préférence un numéro > 1024)
>
Messages postés
3668
Date d'inscription
jeudi 16 juin 2005
Statut
Membre
Dernière intervention
11 janvier 2021

Ne pas oublier que le serveur IIS permet d'avoir la fonction "Bureau à distance" sur XP Pro. quand on a gouté au bureau à distance, on ne le quitte plus ! C'est pour çà qu'il est préférable de changer le port d'Apache sur un port > 1024. En général on utilise les ports 81, 8080, 8081, 8082, ...

Par contre, une question au passage : pourquoi installer Apache alors que vous avez IIS par défaut dans tous les Windows 32 bits (2000,2003,XP,Vista) ?

Je vous confirme que mon serveur IIS, Php, Mysql fonctionne à la perfection et que Apache, dans le cas d'un serveur perso, n'apporte rien. Par contre si vous avez un serveur dédié chez un hébergeur, il est conseillé, pour des questions de performance, d'utiliser Linux (sans interface graphique) et obligatoirement Apache.
Messages postés
23075
Date d'inscription
samedi 22 octobre 2005
Statut
Modérateur
Dernière intervention
19 janvier 2021
2 187 >
Messages postés
3668
Date d'inscription
jeudi 16 juin 2005
Statut
Membre
Dernière intervention
11 janvier 2021

là ce serait vraiment mieux car les deux fonctionneraient sans problème de cohabitation ! question à 1000pts : pourquoi '1024' ?
@mitiés
b g
Messages postés
3668
Date d'inscription
jeudi 16 juin 2005
Statut
Membre
Dernière intervention
11 janvier 2021
981 >
Messages postés
23075
Date d'inscription
samedi 22 octobre 2005
Statut
Modérateur
Dernière intervention
19 janvier 2021

« Lorsqu'un logiciel client veut dialoguer avec un logiciel serveur, aussi appelé service, il a besoin de connaître le port écouté par ce dernier. Les ports utilisés par les services devant être connus par les clients, les principaux types de services utilisent des ports qui sont dits réservés. Par convention, ce sont tous ceux compris entre 0 et 1 023 inclus et leur utilisation par un logiciel serveur nécessite souvent que celui ci s'exécute avec des droits d'accès particulier. Les services utilisant ces ports sont appelés les Well-Known Services (les services les plus connus). »

Source : https://fr.wikipedia.org/wiki/Port_%28logiciel%29

Donc en fait, jusqu'à 1023, les ports sont réservés à des applications spécifiques. En fait, de façon générale, il vaut mieux utiliser un port assez élevé. Cela va jusqu'à 65 536, y a le choix !

edit : article plus complet, mais en Anglais : https://en.wikipedia.org/wiki/List_of_TCP_and_UDP_port_numbers
Messages postés
8
Date d'inscription
vendredi 2 janvier 2009
Statut
Membre
Dernière intervention
12 novembre 2009
>
Messages postés
23075
Date d'inscription
samedi 22 octobre 2005
Statut
Modérateur
Dernière intervention
19 janvier 2021

salut Reivax962,

Je me permets une petite précision, le nombre de ports est codé sur 16 bits ce qui offre bien 65536 possibilités. Mais comme dans notre bonne vieille base 10 qui offre elle 10 possibilités, le chiffre le plus élevé est 9 et non 10. Eh oui, il y a le 0. Le numéro du port le plus élevé est donc 65535.

Précision mesquine ? les maths supportent mal l'approximation d'autant plus que nativement n'importe quel système informatique ne sait compter que jusqu'à 1, d'où la numération binaire et ses dérivés dont l'hexadécimal.
Bonjour,
faites Démarrer => excecuter => et taper "iisreset /stop"
le processus inetinfo va etre stoper totalement
Merci Gaston, ta réponse à résolu mon problème.
mais j'ai fait Démarrer => Exécuter => et taper "iisreset"
j'est le même problème me ta commande ne fonctionne pas
Merci à toi Reivax962, j'ai (enfin) réussi à configurer mon EasyPHP comme il faut ! : D
Messages postés
177
Date d'inscription
mercredi 14 novembre 2007
Statut
Membre
Dernière intervention
1 juin 2010
65
Bonjour à tous.

J'ai le même problème que tous ici. J'ai essayé de changer la conf Apache mais EasyPHP fait sa tête de mule et refuse de m'écouter.
J'ai modifier le port d'écoute dans httpd.conf en remplaçant le Listen 127.0.0.1:80 par Listen 0.0.0.0:8080 mais quand je cherche à démarrer Apache, easyPHP m'affiche un message d'erreur m'indiquant que 'Le port d'Apache2 (80) est occupé par "" (System) !'. Je ne peux malheureusement pas désactiver le process, d'abord parce que je ne sais pas lequel c'est et ensuite parce que j'agis sur une machine distante (et si je supprime sans le faire exprès le IIS ça le fera pas vraiment :s).

Si quelqu'un a une solution je suis preneur ^^
Bonjour,

Voici ce kil faut faire

1- modifier la ligne d'écoute dans httpd.conf
ex: Avant ==> Listen 127.0.0.1:80 Après ==> #Listen 127.0.0.1:8081

2- Clicker sur le E de la fenêtre EasyPHP
Aller dans Configuration -> EasyPHP
Décocher l'option "Vérifier que les ports ne sont pas utilisés par d'autres serveurs..."

Après ça ça fonctionne sans problème

BONNE CHANCE
Merci de ton aide.
allez a configuration ou CTRL+E desactiver l'option Verifier que les ports ne sont pas utilisé par d'autre serveurs.
ca marche tres bien MERCI A VOUS LES JENIES SANS VOUS Y'A PAS D'APACHE
Tu peux également changer le port 80 par un autre port mais il faut modifier un fichier conf de easy php
Messages postés
23075
Date d'inscription
samedi 22 octobre 2005
Statut
Modérateur
Dernière intervention
19 janvier 2021
2 187
bonjour
ben vous voyez que sur un forum comme celui-ci on trouve toujours son bonheur !
vous allez pouvoir enfin le faire démarrer 'easy'
@mitiés
b g
Messages postés
4
Date d'inscription
mardi 3 juillet 2007
Statut
Membre
Dernière intervention
3 juillet 2007

mais, qu'en est-il dans un environnement RedHat ?

en Apache 2.0, la directive Listen 192.168.13.11:8080 devrait en principe forcer le serveur à se mettre en listen sur le port 8080, à la place du port 80 (port par défaut)

or j'ai le même type d'erreur :
(13)Permission denied: make_sock: could not bind to address [::]:80
no listening sockets available, shutting down

l'objectif est d'avoir 2 serveurs Apache, le premier (existant) sur le port 80 (ok), le 2eme sur le port 8080 (ko) ... :-(

une explication ?
merci
Messages postés
3668
Date d'inscription
jeudi 16 juin 2005
Statut
Membre
Dernière intervention
11 janvier 2021
981
Bonjour,

Dans mon httpd.conf, j'ai également une ligne
Port 80

Peut-être devrais-tu essayer d'agir dessus ?

Xavier
Messages postés
4
Date d'inscription
mardi 3 juillet 2007
Statut
Membre
Dernière intervention
3 juillet 2007

ok, merci de ta réponse

d'après mes recherches, les directives BindAddress et Port <n> étaient valides avec les versions Apache 1.x
mais plus en 2.0 ! (j'ai essayé)

en principe, c'est la directive Listen qui les remplace ...

une écoute sur le port 80 serait-elle obligatoire ... ?

à+
non tu peux changer le port d'ecoute d'apache2 en changeant la ligne 'listen' dans httpd.conf

listen 127.0.0.1:81

par contre pour supprimer le message d'erreur au lancement d'easyphp il faut aussi modifier le fichier de config d'easyphp:
(vu sur http://www.easyphp.org/forums/read.php?f=7&i=123428&t=123428 )

voici la solution : changer EasyPHP.ini qui ressemble à présent à :


[EasyPhp]
AutoStartServers=Y
AutoStartEasyPhp=N
AutoReloadConf=Y
CheckVersion=N
StartAsServices=N
ShowAlways=N
ExpandPos=Y
CheckServerPorts=N
Lang=English


J'ai changé CheckServerPorts=Y en CheckServerPorts=N pour éviter le check
Bonjour, j'ai un probleme dans le port 80 lors de l'instalation de l'apache 2.0.54 il affiche que le service de port 80 et impossble
salut tous le monde
la solution est tres simple
suivre les etape:
clique droite sur poste de travail choisir gerer
allez services et applications clique sur services internet IIS
2 clique sur sites web
boutan droite choisi arreter

le port est dective

bonne chance
Bonjour,

tout petit up ^^

En fait, je me connecte sur un serveur en local (bureau à distance).
Si je stop IIS, y aura t-il des problèmes pour ce connecter à nouveau au serveur?

J'ai changé le port 80 mais tjr le même message d'erreur et toujours pas lancé le serv apache.
Messages postés
1
Date d'inscription
dimanche 11 janvier 2009
Statut
Membre
Dernière intervention
15 janvier 2009

bonjour,
presque j'ai le même problème
dans un réseau locale si je lance easyphp2.0b1, le easy ne démarre pas, une fenêtre de démarrage s'ffiche et elle persiste affichée. mais si je déconnecte un PC et je démarre easy il se lance? pouvez-vous m'aider pour résoudre se problème.
je suis vraiment faciné des interventions des internautes et leurs réponse pertinentes!!!!!!
a++
Messages postés
20
Date d'inscription
vendredi 28 mars 2008
Statut
Membre
Dernière intervention
16 avril 2011
7
Pour repérer facilement ce qui est A modifier, tu peux facilement retrouver le port A changer A la ligne 62 ou 63 du fichier httpd.conf

mer6 beaucoup ca m'a aidé vraiment merci

la bonne solution
Merci asseck pour cette réponse, claire et nette.
Ca marche !
J'ai eu le même problème que toi.

Démarrer>Executer service.msc

Là, désactiver le service Administration IIS
Salut,
c'est une peut-être une manière de contourner le problème mais ce n'Est pas une solution! Je ne comprends pas pourquoi EasyPHP devrait toujours utiliser le port 80 si on change la ligne Listen 127.0.0.1:80 à 127.0.0.1:8080.

Pourquoi est-il possible - comme chez moi - que après on a toujours le même message? Y-a-til d'autres endroits À modifier?

Merci pour l'aide, je ne voudrais pas arrêter le service IIS.

A+
Messages postés
3668
Date d'inscription
jeudi 16 juin 2005
Statut
Membre
Dernière intervention
11 janvier 2021
981
Bonjour,

Ça dépend des versions d'apache, mais il me semble qu'il y a aussi une instruction
Port 80
Sur laquelle tu pourrais jouer.
Dans le doute, recherche toutes les occurrences de « 80 » dans ton fichier httpd.conf

Xavier
Salut,
merci pour la réponse. Le problème c'est que j'utilise EasyPHP 3.0 puisque c'est la seule pour laquelle il y a la possibilité d'intégrer PostGreSQL comme je voudrais le faire. Je n'ai jamais eu des problèmes avec la version 5.3.7 mais pour celle-ci l'intégration de postgreSQL apparaît difficile (voir impossible pour moi) et il y a personne sur la forum qui me donne une réponse.

C'est pour cela que je voulait utiliser la version 3.0. et la faire marcher.
Je viens d'abandonner puisque malgré toutes mes tentatives à démarrer Apache il me dit "port 80" est occupé" et je ne vois pas quel autre ligne on pourrait travailler. J'ai cherché partout ds le fichier...

A+

Thommy7571

La solution exacte:(Il faut désinstaller IIS)
1- Panneau de configuration
2- Ajouter supprimer des programmes
3-Ajoute ou supprimer des composants windows
4- Décocher "Services Internet (IIS)"
5- Suivant...
6- Terminer
salut ! si ça ne suffit pas et pour les autres
pour ceux qui on developper avec visual studio, expression web, ect...
le service à arreter pour debloquer le port 80 est : "service de l'agent de déploiement web"
Pour inetinfo.exe qui occupe le port 80 empéchant apache de se démarrer, voici la solution:
Faites Demarrer > Executer
Tape services.msc (ou service.msc) puis Entrée

Le service correspondant est Administration IIS, faites click droit dessus et Arreter. Vous pouvez faire click droit--> propriétés puis sur le l'onglet Type de démarrage vous choisissez Manuel, ainsi même si tu redémarres ton ordinateur ce service ne démarrera, donc tu le démarres que si tu en as besoin.

Ce service Administration IIS est un outil de Microsoft qui met en oeuvre le protocole SMTP pour l'envoi de Mail, il peut occuper souvent se port, mais pour l'envoi il occupe généralement le port 25 qui est son port par défaut. Courage
MERCI 0 TOI POOF65
j'avais le même pb, et cela me l'a résolu.
Merci à toi asseck.