Aide formule SI (5 conditions) Excel [Résolu/Fermé]

Signaler
-
 Folla -
Bonjour,

Je souhaiterai de l'aide concernant une formule Excel. Je m'explique,
je souhaite rassembler 5 formules en une comme suit :
Si la cellule < 180 alors la réponse sera 2
Si la cellule >180 mais <360 alors la réponse sera 3
Si la cellule >360 mais <540 alors la réponse sera 4
Enfin si la cellule >540 mais <720 alors la réponse sera 5.

Je dois avouer avoir beaucoup cherché mais pas moyen, peut être un soucis de virgule, de parenthèse. Merci d'avance

3 réponses

Messages postés
7391
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
28 août 2020
3 049
salut

=SI(A1<180;2;SI(ET(A1>180;A1<360);3;SI(ET(A1>360;A1<540);4;SI(ET(A1>540;A1<720);5;""))))

attention tu indiques du strictement sup ou inf mais si c'est égal à 180 ou 360... ?
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
7391
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
28 août 2020
3 049
alors mettre >= ou <= aux bons endroits dans la formule
La formule copiée à l'identique ne m'affiche au final aucune valeur. Exemple pour la première valeur dans la cellule visée : 329
La formule est bonne, il faut juste que tu changes A1 par la cellule que tu souhaites
Merci, en fait, les cellules visées étaient "sous forme de texte", je les ai donc converties en nombre et tout a fonctionné. Merci à vous tous pour votre réactivité et précieuse aide.
Good evening!
please I need help in fonction Si with 5 conditions ???
Messages postés
4237
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 259
Bonjour,

pouvez-vous nous indiquer votre version d'Excel, ainsi que la formule que vous avez commencé à écrire ?

Cordialement.
La version d'Excel est 2007.
=SI(A1<180;2;SI(ET(A1>180;A1<360);3;SI(ET(A1>360;A1<540);4;SI(ET(A1>540;A1<720);5;""))))

J'ai tout bonnement repris la première des réponses à ma question. Merci.
Messages postés
12186
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
15 octobre 2020
2 496
Bonjour,
Généralité :
Test sur la valeur contenue en A1, écrire en B1 :
=SI(A1<180;2;SI(A1<360;3;SI(A1<540;4;SI(A1<720;5;"Valeur erronée"))))
ton cas particulier :
=ENT(A1/180)+2
ou :
=SI(A1<720;ENT(A1/180)+2;"Valeur erronée")
Cordialement,
Franck P