BleachBit, Wine, AutoIT [Résolu/Fermé]

Signaler
-
Messages postés
29801
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
12 mai 2021
-
Bonjour,

* Ma première question est celle-ci, puis-je avoir un outil pour bosser mon AutoIT sous ma Debian ?

* La deuxième, je lance des applications Windows toujours sous ma Debian avec "Wine", mais il ne les lance pas toujours, auriez-vous mieux à me proposer ?

* Les dépôts c'est bien mais par exemple, la version de Bleachbit (0.9) est sortie, mais seule la version 0.8.8.1 est disponible sur les dépôts, j'ai aussi ce cas : https://forums.commentcamarche.net/forum/affich-22542452-chromium-v6-ou-v14
Peut-on le signaler ?

Merci pour vous réponses ;-)



O.o°*¤.L'erreur est la règle, la vérité est l'accident de l'erreur.°.O°ºø

4 réponses

Messages postés
596
Date d'inscription
mardi 9 février 2010
Statut
Membre
Dernière intervention
30 juin 2015
94
AutoIT avec debian c'est assé stupide, ya rien mieux que Wine et les sources ça existe

AutoIT avec debian c'est assé stupide

Et bien, je vais avancer avec des commentaires de la sorte...

Pour info c'est pour pouvoir continuer à développer lorsque je serrai en déplacement, et que je n'aurais que mon pc Linux (Debian)
Messages postés
596
Date d'inscription
mardi 9 février 2010
Statut
Membre
Dernière intervention
30 juin 2015
94
reformule ta première question, car c'est pas très compréhensible
Utilisateur anonyme
Euh, il y a 3 questions... Ci-dessus ce n'est pas une question, mais une affirmation.
Messages postés
596
Date d'inscription
mardi 9 février 2010
Statut
Membre
Dernière intervention
30 juin 2015
94
justement, ta première question
Utilisateur anonyme
Ben, elle est clair, comme AutoIT V3, mais pour Linux.
Messages postés
1428
Date d'inscription
mercredi 29 juillet 2009
Statut
Contributeur
Dernière intervention
24 janvier 2019
88
Salut,
pour répondre à ta dernière question si tu veux les dernier paquets, jette un coup d'oeil du côté de la branche testing. Debian est faite pour être hyper stable donc il y a seulement des correctifs appliqués aux logiciels. C'est ce côté "figé" qui m'a fait passer à autre chose, jongler avec une testing, ce n'est pas super, mais ça reste une bonne distribution très stable.

Pour ton problème d'application windows sous Debian, je dis un truc au hasard pour une alternative mais as-tu pensé aux machines virtuelles ?

Excuse ma curiosité mais je vois que AutoIT est un langage de script, dans quel cadre utilises-tu ça si ce n'est pas indiscret ?
All software sucks.
Alan Cox
Utilisateur anonyme
Génial ! Merci beaucoup de ta réponse :-)

* Comment puis-je faire pour passer en distribution testing ? Ou du moins, avoir les paquets testing ?

* Oui, j'ai pensé à la machine virtuelle, mais je suis sous un pc qui a une dizaine d'année, donc pas assez puissant..

* L'AutoIT, car j'ai développé une Application nommée Slowin' Killer, j'en ai fais par ici : https://forums.commentcamarche.net/forum/affich-23017254-proposition-de-logiciel-slowin-killer
Messages postés
29801
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
12 mai 2021
7 089
Pour commencer Sachaaa : 3 questions => 3 sujets.

- Tu comprendras que la discussion va forcément devenir incompréhensible pour quelqu'un qui tombe dessus.

- Le sujet ne sera clos que si l'on répond au 3.

- Si quelqu'un fait une recherche par exemple sur bleachbit et tombe sur ce sujet il devra éplucher tout le fil de discussion pour trouver les morceaux qui l'intéresse.

Si j'étais tombé sur le fil de discussion plus tôt je l'aurais directement supprimé en te demandant de créer 3 fils de discussions distincts, mais bon, comme des gens ont commencé à répondre on ne va pas saper leur travail.

1) Aucune idée je ne connais pas cet outil. Mais de ce qu'on voit ici c'est un outil windows : http://doc.ubuntu-fr.org/gui_scripts donc bof sous windows même si on peut sans doute s'en sortir avec wine à défaut de trouver un équivalent linux. En tout cas ce lien à au moins le mérite de te donner quelques équivalents linux.

2) Non c'est le mieux en terme de performances. Ceci dit les applications windows peuvent être plus facile à faire tourner avec des surcouches de wine (playonlinux...) ou des alternatives (crossover). Les dernières versions de wine sont plus performantes également (par exemple la version 1.3 tourne mieux que la 1.0.1) . S'il s'agit d'un jeu utilisant de la 3D, il est clair que le pilote utilisé a également beaucoup d'influence (par exemple pour les cartes nvidia).

3) Bleachbit existe en version 0.9 en version unstable :
https://packages.debian.org/sid/bleachbit

Tu peux installer certains paquets dans une autre release de debian (par exemple si tu es en testing, tu peux avoir des paquets unstable installés proprement grâce à /etc/apt/preferences). Plus de détails ici :
http://www.mistra.fr/tutoriel-linux-apt-configuration.html

Bonne chance
Bonjour,

- J'aurais dû effectivement faire trois sujets, mais je ne voulais pas "encrasser" la section.
Mais lorsque l'on y songe pour l'internaute en effet c'est bête de ma part, excuse moi.

* Merci pour ton lien sur la testing, je vais regarder ça plus en détail.

* Pour ce qui est de BleachBit, je l'avais installé depuis leur site, mais c'est le soucis de dépôts qui me chagrinait..

Merci à toi.

Edit: J'ai suivie ton lien "http://www.mistra.fr/tutoriel-linux-apt-configuration.html", et j'ai des erreurs lors de "l'aptitude update", ainsi que des "en conflit lors de "l'aptitude safe-upgrade"...

Je vais ouvrir un nouveau poste, désolé pour celui-ci.
https://forums.commentcamarche.net/forum/affich-23060842-probleme-de-depots#p23063606
Messages postés
29801
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
12 mai 2021
7 089
- J'aurais dû effectivement faire trois sujets, mais je ne voulais pas "encrasser" la section. Mais lorsque l'on y songe pour l'internaute en effet c'est bête de ma part, excuse moi.

Je préfère trois sujets clairs qu'un fil de discussion encrassé personnellement ;-)

* Pour ce qui est de BleachBit, je l'avais installé depuis leur site, mais c'est le soucis de dépôts qui me chagrinait..

Avec /etc/apt/preferences, plus de soucis de dépôts. Tu peux dire que tu utilises une distribution par exemple testing/unstable en privilégiant les paquets testings, puis installer bleachbit avec la commande :

aptitude install -t unstable bleachbit


Edit: J'ai suivie ton lien "http://www.mistra.fr/tutoriel-linux-apt-configuration.html", et j'ai des erreurs lors de "l'aptitude update", ainsi que des "en conflit lors de "l'aptitude safe-upgrade"...

Ok je vais regarder.